aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2003-06-20 21:31:51 +0800
committerache <ache@FreeBSD.org>2003-06-20 21:31:51 +0800
commit3a762bc2c760708a9509251b12d5ed7687ceaf13 (patch)
tree8c2a8c3f8e9cceda45a875b83e1a4d204821c24c /graphics
parentaab80bda859a43bcfe659cc00dbb0f478171f7d0 (diff)
downloadfreebsd-ports-gnome-3a762bc2c760708a9509251b12d5ed7687ceaf13.tar.gz
freebsd-ports-gnome-3a762bc2c760708a9509251b12d5ed7687ceaf13.tar.zst
freebsd-ports-gnome-3a762bc2c760708a9509251b12d5ed7687ceaf13.zip
Restore LZW knob, not expired yet in Europe and Japan.
Autoenable it, if USA_RESIDENT == YES
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile8
-rw-r--r--graphics/gd2/Makefile21
2 files changed, 28 insertions, 1 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 93922cb3893e..39db8427caef 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -50,7 +50,7 @@ LIBTOOLFLAGS= # none
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-shared --with-perl=${PERL5} \
- --without-gslib --enable-lzw
+ --without-gslib
INSTALLS_SHLIB= yes
MAN1= ImageMagick.1 Magick++-config.1 Magick-config.1 \
@@ -78,6 +78,12 @@ CONFIGURE_ARGS+= --without-threads
CONFIGURE_ARGS+= --with-quantum-depth=8
.endif
+# Produce standard (small) GIFs
+.if defined(HAVE_UNISYS_LICENSE) || \
+ (defined(USA_RESIDENT) && ${USA_RESIDENT} == "YES")
+CONFIGURE_ARGS+= --enable-lzw
+.endif
+
# Loadable coders, smaller executable, but PerlMagick not really works
# ('make test' there works)
.if defined(WITH_IMAGEMAGICK_MODULES)
diff --git a/graphics/gd2/Makefile b/graphics/gd2/Makefile
index d89bf3167e0a..0c619802b6e0 100644
--- a/graphics/gd2/Makefile
+++ b/graphics/gd2/Makefile
@@ -41,9 +41,30 @@ MAKE_ARGS+= -j2
MAKE_ARGS+= $v="${$v}"
.endfor
+.if defined(HAVE_UNISYS_LICENSE) || \
+ (defined(USA_RESIDENT) && ${USA_RESIDENT} == "YES")
+WITH_LZW= yes
+.endif
+
+.if !defined(WITH_LZW)
+pre-fetch:
+ @${ECHO_CMD} "************************************************************"
+ @${ECHO_CMD} "* If you live outside US and Canada, you can define *"
+ @${ECHO_CMD} "* WITH_LZW to enable GIF compression support. *"
+ @${ECHO_CMD} "************************************************************"
+.endif
+
post-extract:
@${CP} ${FILESDIR}/g* ${WRKSRC}
+post-patch:
+.if !defined(WITH_LZW)
+ ${MV} ${WRKSRC}/gd_gif_out.c ${WRKSRC}/gd_gif_out.c.nogif && \
+ ${SED} -e "s|#define LZW_LICENCED||g" \
+ < ${WRKSRC}/gd_gif_out.c.nogif \
+ > ${WRKSRC}/gd_gif_out.c
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}