aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-08 00:53:11 +0800
committerwg <wg@FreeBSD.org>2014-10-08 00:53:11 +0800
commit3bb31167975c91bd974359a542e01bbc17a5a37c (patch)
treefc6d9ecce9a782050f337f49aa45086746a859be /graphics
parent04385bd0074a8bfb6689284134a27b706dac40d1 (diff)
downloadfreebsd-ports-gnome-3bb31167975c91bd974359a542e01bbc17a5a37c.tar.gz
freebsd-ports-gnome-3bb31167975c91bd974359a542e01bbc17a5a37c.tar.zst
freebsd-ports-gnome-3bb31167975c91bd974359a542e01bbc17a5a37c.zip
graphics/py-pyggel: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pyggel/Makefile10
-rw-r--r--graphics/py-pyggel/files/patch-pyggel__include.py11
2 files changed, 15 insertions, 6 deletions
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
index 83addbac65aa..5d5250041de3 100644
--- a/graphics/py-pyggel/Makefile
+++ b/graphics/py-pyggel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pyggel
PORTVERSION= 0.08
DISTVERSIONSUFFIX= -alpha4c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME:tu}-V${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -23,14 +23,12 @@ LICENSE_PERMS_Public_Domain=dist-mirror dist-sell pkg-mirror pkg-sell auto-accep
RUN_DEPENDS= ${PYNUMPY} \
${PYGAME} \
${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
- ${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:${PORTSDIR}/graphics/py-pillow
-USES= dos2unix zip
+USES= dos2unix python:2 zip
DOS2UNIX_GLOB= *.mtl *.py *.txt
-USE_PYTHON= 2
+USE_PYTHON= autoplist distutils
NO_BUILD= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
PORTDOCS= Readme.txt
PORTEXAMPLES= *
diff --git a/graphics/py-pyggel/files/patch-pyggel__include.py b/graphics/py-pyggel/files/patch-pyggel__include.py
new file mode 100644
index 000000000000..8b429a1d6caa
--- /dev/null
+++ b/graphics/py-pyggel/files/patch-pyggel__include.py
@@ -0,0 +1,11 @@
+--- pyggel/include.py.orig 2014-10-07 16:52:11 UTC
++++ pyggel/include.py
+@@ -27,7 +27,7 @@
+ ANI_AVAILABLE = False
+
+ try:
+- import Image as PIL
++ from PIL import Image as PIL
+ PIL_AVAILABLE = True
+ except:
+ PIL_AVAILABLE = False