aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2010-09-27 06:11:22 +0800
committeritetcu <itetcu@FreeBSD.org>2010-09-27 06:11:22 +0800
commit3d62b0469c3bdafe292550613fe9222c3f2ef7c7 (patch)
treedc1f7a53b0ddd3709aaf05de39d2ad1c09c7399a /graphics
parentbc4ff6884438524b022bec767a36125eb512bcfe (diff)
downloadfreebsd-ports-gnome-3d62b0469c3bdafe292550613fe9222c3f2ef7c7.tar.gz
freebsd-ports-gnome-3d62b0469c3bdafe292550613fe9222c3f2ef7c7.tar.zst
freebsd-ports-gnome-3d62b0469c3bdafe292550613fe9222c3f2ef7c7.zip
The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source
C/C++ extension loading library. GLEW provides efficient run-time mechanisms for determining which OpenGL extensions are supported on the target platform. OpenGL core and extension functionality is exposed in a single header file. GLEW has been tested on a variety of operating systems, including Windows, Linux, Mac OS X, FreeBSD, Irix, and Solaris. This is the linux verson. WWW: http://glew.sourceforge.net/ PR: ports/150742 Submitted by: Eitan Adler <lists at eitanadler.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-f10-glew/Makefile24
-rw-r--r--graphics/linux-f10-glew/distinfo.i3866
-rw-r--r--graphics/linux-f10-glew/pkg-descr10
-rw-r--r--graphics/linux-f10-glew/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d197a4b1dcd1..cc66673ad92a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -495,6 +495,7 @@
SUBDIR += linux-f10-cairo
SUBDIR += linux-f10-dri
SUBDIR += linux-f10-gdk-pixbuf
+ SUBDIR += linux-f10-glew
SUBDIR += linux-f10-imlib
SUBDIR += linux-f10-jpeg
SUBDIR += linux-f10-libGLU
diff --git a/graphics/linux-f10-glew/Makefile b/graphics/linux-f10-glew/Makefile
new file mode 100644
index 000000000000..d199c512be64
--- /dev/null
+++ b/graphics/linux-f10-glew/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: graphics/linux-f10-glew
+# Date created: 2010-09-19
+# Whom: Eitan Adler <lists@eitanadler.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glew
+PORTVERSION= 1.5.1
+CATEGORIES= graphics linux
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= lists@eitanadler.com
+COMMENT= OpenGL Extension Wrangler Library (Linux Fedora 10)
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_NAME= glew
+LINUX_DIST_VER= 10
+RPMVERSION= 1.fc10
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-f10-glew/distinfo.i386 b/graphics/linux-f10-glew/distinfo.i386
new file mode 100644
index 000000000000..36ed90233929
--- /dev/null
+++ b/graphics/linux-f10-glew/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/10/glew-1.5.1-1.fc10.i386.rpm) = 50c245e182b8303489a2c0e32d6d6895
+SHA256 (rpm/i386/fedora/10/glew-1.5.1-1.fc10.i386.rpm) = 61751e511d0e8eea7417da042189cc613e69db0f8dea71f4c94d3056ba3cb305
+SIZE (rpm/i386/fedora/10/glew-1.5.1-1.fc10.i386.rpm) = 172334
+MD5 (rpm/i386/fedora/10/glew-1.5.1-1.fc10.src.rpm) = 792ca5b0af502cc937fcbb66bc09facf
+SHA256 (rpm/i386/fedora/10/glew-1.5.1-1.fc10.src.rpm) = 35a6080784bab054d9a4e30a74811f4ce84398c1e278739292cf94269af70fb7
+SIZE (rpm/i386/fedora/10/glew-1.5.1-1.fc10.src.rpm) = 400909
diff --git a/graphics/linux-f10-glew/pkg-descr b/graphics/linux-f10-glew/pkg-descr
new file mode 100644
index 000000000000..17d4b7759a61
--- /dev/null
+++ b/graphics/linux-f10-glew/pkg-descr
@@ -0,0 +1,10 @@
+The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source
+C/C++ extension loading library. GLEW provides efficient run-time mechanisms
+for determining which OpenGL extensions are supported on the target platform.
+OpenGL core and extension functionality is exposed in a single header file.
+GLEW has been tested on a variety of operating systems, including Windows,
+Linux, Mac OS X, FreeBSD, Irix, and Solaris.
+
+This is the linux verson.
+
+WWW: http://glew.sourceforge.net/
diff --git a/graphics/linux-f10-glew/pkg-plist b/graphics/linux-f10-glew/pkg-plist
new file mode 100644
index 000000000000..3d585838aa21
--- /dev/null
+++ b/graphics/linux-f10-glew/pkg-plist
@@ -0,0 +1,10 @@
+usr/bin/glewinfo
+usr/bin/visualinfo
+usr/lib/libGLEW.so.1.5.1
+%%PORTDOCS%%usr/%%DOCSDIR%%-1.5.1/LICENSE.txt
+%%PORTDOCS%%@dirrm usr/%%DOCSDIR%%-1.5.1
+@dirrm usr/share/doc
+@dirrm usr/share
+@dirrm usr/lib
+@dirrm usr/bin
+@dirrm usr