aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-09-13 14:19:26 +0800
committerwen <wen@FreeBSD.org>2012-09-13 14:19:26 +0800
commit3e9792cd1735b5c4651e23d1bd55942a0e87ff02 (patch)
tree7101ab89873fff4261cc4bf2cc2b5116dac85bd2 /graphics
parent0f76b13df02e70b6ab6c9de4578c74d6c26a9898 (diff)
downloadfreebsd-ports-gnome-3e9792cd1735b5c4651e23d1bd55942a0e87ff02.tar.gz
freebsd-ports-gnome-3e9792cd1735b5c4651e23d1bd55942a0e87ff02.tar.zst
freebsd-ports-gnome-3e9792cd1735b5c4651e23d1bd55942a0e87ff02.zip
- Fix build with WMS and WFS option
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapserver/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 9f34312bc98d..962cce665759 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -85,14 +85,16 @@ CONFIGURE_ARGS+= --with-pdf=${LOCALBASE} --with-tiff=${LOCALBASE} --with-png=${L
.endif
.if ${PORT_OPTIONS:MWMS}
-WITH_CURL= yes
-CONFIGURE_ARGS+= --with-wms --with-wmsclient
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl=${LOCALBASE} --with-wms --with-wmsclient
.endif
.if ${PORT_OPTIONS:MWFS}
-WITH_CURL= yes
-WITH_GDAL= yes
-CONFIGURE_ARGS+= --with-wfs --with-wfsclient
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
+ gdal:${PORTSDIR}/graphics/gdal
+CONFIGURE_ARGS+= --with-wfs --with-wfsclient --with-curl=${LOCALBASE} \
+ --with-gdal=${LOCALBASE}/bin/gdal-config \
+ --with-ogr=${LOCALBASE}/bin/gdal-config
.endif
.if ${PORT_OPTIONS:MGDAL}