aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2000-12-31 02:43:12 +0800
committersf <sf@FreeBSD.org>2000-12-31 02:43:12 +0800
commit450545cce381001b0f297c48a4cf4a9da27634e3 (patch)
tree2cb7cf020bdf7a59c0e0af58ac6992c09de7f7a3 /graphics
parentce1011d2f2553d32af61c50567870fd97a7b746e (diff)
downloadfreebsd-ports-gnome-450545cce381001b0f297c48a4cf4a9da27634e3.tar.gz
freebsd-ports-gnome-450545cce381001b0f297c48a4cf4a9da27634e3.tar.zst
freebsd-ports-gnome-450545cce381001b0f297c48a4cf4a9da27634e3.zip
Correct manpage handling with XFree86-4.
honor CFLAGS. supress <malloc.h> warnings. split patch-aa into patch-a[acd]. PR: 23445 Submited by: myself Approved by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/plotmtv/Makefile5
-rw-r--r--graphics/plotmtv/files/patch-aa22
-rw-r--r--graphics/plotmtv/files/patch-ac8
-rw-r--r--graphics/plotmtv/files/patch-ad5
4 files changed, 29 insertions, 11 deletions
diff --git a/graphics/plotmtv/Makefile b/graphics/plotmtv/Makefile
index 3c0093dd9388..084640aa69eb 100644
--- a/graphics/plotmtv/Makefile
+++ b/graphics/plotmtv/Makefile
@@ -17,12 +17,13 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= giffunip@asme.org
USE_IMAKE= yes
-NO_INSTALL_MANPAGES= yes
ALL_TARGET= World
MAN1= plotmtv.1
+post-patch:
+ find ${WRKSRC} -name \*.c | xargs ${PERL} -pi.malloc.h -e 's/<malloc.h>/<stdlib.h>/'
+
post-install:
- @${INSTALL_MAN} ${WRKSRC}/Docs/plotmtv.man ${PREFIX}/man/man1/plotmtv.1
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/plotmtv/Tests
@${INSTALL_DATA} ${WRKSRC}/Docs/DataFormat.ps.Z \
diff --git a/graphics/plotmtv/files/patch-aa b/graphics/plotmtv/files/patch-aa
index 1a558ce952f7..106d12ba27a7 100644
--- a/graphics/plotmtv/files/patch-aa
+++ b/graphics/plotmtv/files/patch-aa
@@ -1,9 +1,13 @@
-*** Imakefile~ Sat Jul 15 04:07:13 1995
---- Imakefile Sat Jan 18 07:02:38 1997
-***************
-*** 22,23 ****
-! CDEBUGFLAGS = -g
-! DEFINES = -DPRINTER_NAME=\"hpps\" -DPRINTER_CMD=\"lpr\ -h\"
---- 22,23 ----
-! CDEBUGFLAGS = -O3
-! DEFINES = -DPRINTER_NAME=\"S\" -DPRINTER_CMD=\"lpr\ -h\"
+--- Imakefile.orig Sat Jul 15 04:07:13 1995
++++ Imakefile Wed Nov 1 07:54:28 2000
+@@ -19,9 +19,8 @@
+ #define IHaveSubdirs
+ #define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS) $(DEFINES)'
+
+- CDEBUGFLAGS = -g
+ DEFINES = -DPRINTER_NAME=\"hpps\" -DPRINTER_CMD=\"lpr\ -h\"
+- PROGRAMDIRS = Lib Plot
++ PROGRAMDIRS = Lib Plot Docs
+ UTILITIESDIR = Utils
+ LOCALBINDIR = ./Bin
+ SUBDIRS = $(PROGRAMDIRS) $(UTILITIESDIR)
diff --git a/graphics/plotmtv/files/patch-ac b/graphics/plotmtv/files/patch-ac
new file mode 100644
index 000000000000..d943bbb1ee9b
--- /dev/null
+++ b/graphics/plotmtv/files/patch-ac
@@ -0,0 +1,8 @@
+--- Plot/Imakefile.orig Sat Jul 15 04:23:15 1995
++++ Plot/Imakefile Wed Nov 1 07:37:12 2000
+@@ -31,4 +31,4 @@
+ install.local:: all $(PROGRAM)
+ $(INSTALL) -c $(INSTPGMFLAGS) $(PROGNAME) $(LOCALBINDIR)
+
+-ComplexProgramTarget($(PROGNAME))
++ComplexProgramTargetNoMan($(PROGNAME))
diff --git a/graphics/plotmtv/files/patch-ad b/graphics/plotmtv/files/patch-ad
new file mode 100644
index 000000000000..fd112fd004db
--- /dev/null
+++ b/graphics/plotmtv/files/patch-ad
@@ -0,0 +1,5 @@
+--- /dev/null Wed Nov 1 07:50:48 2000
++++ Docs/Imakefile Wed Nov 1 07:54:17 2000
+@@ -0,0 +1,2 @@
++InstallManPage(plotmtv, $(MANDIR))
++install.local:: all