aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:33:20 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:33:20 +0800
commit4665e776612f716c4cb8c002a284383b7c2d3af7 (patch)
tree57abe85ea7022579a6eb28cee25c06bc46864fcc /graphics
parent3250eef853c14f4ac32fd93a8f1439bfd74edd2c (diff)
downloadfreebsd-ports-gnome-4665e776612f716c4cb8c002a284383b7c2d3af7.tar.gz
freebsd-ports-gnome-4665e776612f716c4cb8c002a284383b7c2d3af7.tar.zst
freebsd-ports-gnome-4665e776612f716c4cb8c002a284383b7c2d3af7.zip
[PATCH] graphics/epstool: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54928 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epstool/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index a834d7a8a4f6..c57fa3626490 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -13,13 +13,27 @@ MASTER_SITES= ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/
MAINTAINER= ports@FreeBSD.org
COMMENT= Create or extract preview bitmaps in EPS files
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_GMAKE= yes
MAKEFILE= makefile
MAKE_ARGS= CC="${CC}" CDEBUG="${CFLAGS}" LINK="${CC}" EPSLIB=""
ALL_TARGET= ${PORTNAME}
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/epstool