aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-23 14:02:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-23 14:02:39 +0800
commit499282b5b132af59bc2409e174b788451b0e5a54 (patch)
tree5fb713a39574fafdc1672fdd1a701ec13410c6ac /graphics
parent5f5d252d55ec976352c3b61daf4f5f2a8426d6c4 (diff)
downloadfreebsd-ports-gnome-499282b5b132af59bc2409e174b788451b0e5a54.tar.gz
freebsd-ports-gnome-499282b5b132af59bc2409e174b788451b0e5a54.tar.zst
freebsd-ports-gnome-499282b5b132af59bc2409e174b788451b0e5a54.zip
- Disable squish option for now: it breaks dependent ports, at least devel/love07
Diffstat (limited to 'graphics')
-rw-r--r--graphics/devil/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 6bd65658d72c..043826cde8f6 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -4,7 +4,7 @@
PORTNAME= devil
PORTVERSION= 1.7.8
PORTEPOCH= 1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF/openil/DevIL/${PORTVERSION}
DISTNAME= DevIL-${PORTVERSION}
@@ -17,7 +17,8 @@ USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4 -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ARGS= --enable-ILU \
- --disable-allegro --disable-directx8 --disable-directx9
+ --disable-allegro --disable-directx8 --disable-directx9 \
+ --without-libsquish
USE_LDCONFIG= yes
USE_GCC= any
@@ -28,8 +29,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
-OPTIONS_DEFINE= JPEG JASPER LCMS MNG PNG TIFF EXR X11 SDL SQUISH NVTT SIMD DOCS
-OPTIONS_DEFAULT=JPEG JASPER LCMS MNG PNG TIFF EXR X11 SDL SQUISH NVTT DOCS
+OPTIONS_DEFINE= JPEG JASPER LCMS MNG PNG TIFF EXR X11 SDL NVTT SIMD DOCS
+OPTIONS_DEFAULT=JPEG JASPER LCMS MNG PNG TIFF EXR X11 SDL NVTT DOCS
OPTIONS_DEFAULT_amd64=SIMD
JPEG_DESC= Enable JPEG support
@@ -59,8 +60,8 @@ TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
TIFF_CONFIGURE_ENABLE= tiff
EXR_LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
EXR_CONFIGURE_ENABLE= exr
-SQUISH_BUILD_DEPENDS= ${LOCALBASE}/lib/libsquish.a:${PORTSDIR}/graphics/squish
-SQUISH_CONFIGURE_WITH= libsquish
+#SQUISH_BUILD_DEPENDS= ${LOCALBASE}/lib/libsquish.a:${PORTSDIR}/graphics/squish
+#SQUISH_CONFIGURE_WITH= libsquish
NVTT_LIB_DEPENDS= libnvtt.so:${PORTSDIR}/graphics/nvidia-texture-tools
NVTT_CONFIGURE_WITH= nvtt