aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2006-09-01 12:17:44 +0800
committeranholt <anholt@FreeBSD.org>2006-09-01 12:17:44 +0800
commit58400d54709b18b29dbcdb097e5e82da96ea9360 (patch)
treed264bab65675b1446233dc2a95edc9584c43cb80 /graphics
parentb164b95226254c926c81b60d2bd4338ec3809f42 (diff)
downloadfreebsd-ports-gnome-58400d54709b18b29dbcdb097e5e82da96ea9360.tar.gz
freebsd-ports-gnome-58400d54709b18b29dbcdb097e5e82da96ea9360.tar.zst
freebsd-ports-gnome-58400d54709b18b29dbcdb097e5e82da96ea9360.zip
Fix build on 4.x. This is slightly different from the submitted patch, but
I think it should still work. PR: Mark Andrews <Mark_Andrews@isc.org> Submitted by: ports/92704
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 526b88f47544..6e6bcb4550c2 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -28,6 +28,7 @@ USE_GMAKE= yes
MAKE_ENV+= FBSDCC="${CC}" FBSDCXX="${CXX}" \
FBSDCFLAGS="${CFLAGS}" FBSDCXXFLAGS="${CXXFLAGS}" \
PTHREAD_LIBS=${PTHREAD_LIBS}
+USE_GCC= 3.4+
ONLY_FOR_ARCHS= i386 alpha amd64
@@ -59,6 +60,13 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lib/savage_dri.so ${DRIMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/lib/sis_dri.so ${DRIMODDIR}
+.if ${OSVERSION} < 500000
+pre-patch:
+ ${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|g' \
+ ${WRKSRC}/src/mesa/drivers/dri/mga/mga_xmesa.c \
+ ${WRKSRC}/src/mesa/drivers/dri/mga/mgacontext.h
+.endif
+
.if ${ARCH} == i386
PLIST_SUB+= I386=""
PLIST_SUB+= I386_AMD64=""