aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-04-15 16:14:22 +0800
committerdinoex <dinoex@FreeBSD.org>2014-04-15 16:14:22 +0800
commit5d0fd28bf65cf54e68e576d816e7a29d5c033f99 (patch)
tree93b52f83f66e050afe65cb5ae5a154861a9dbc9f /graphics
parente8763435c13c5639b796aa057e8b37c742e25063 (diff)
downloadfreebsd-ports-gnome-5d0fd28bf65cf54e68e576d816e7a29d5c033f99.tar.gz
freebsd-ports-gnome-5d0fd28bf65cf54e68e576d816e7a29d5c033f99.tar.zst
freebsd-ports-gnome-5d0fd28bf65cf54e68e576d816e7a29d5c033f99.zip
- Add shebangfix so bdftogd
- Strip libgd PR: 188581 Submitted by: Steve Wills
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index c47e0df0ecfa..8edcc963aa9f 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgd
PORTVERSION= 2.1.0
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= http://cdn.bitbucket.org/libgd/gd-libgd/downloads/
@@ -18,7 +18,8 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
CONFLICTS= bazaar-1.*
-USES= tar:xz pkgconfig
+USES= tar:xz pkgconfig shebangfix
+SHEBANG_FILES= ${WRKSRC}/src/bdftogd
GNU_CONFIGURE= yes
GNU_CONFIGURE_ENV= PKG_CONFIG_LIBDIR=${LOCALBASE}/libdata/pkgconfig
GNU_CONFIGURE_ARGS=
@@ -105,5 +106,6 @@ pre-build:
post-install:
${INSTALL_DATA} ${WRKSRC}/src/gdhelpers.h \
${STAGEDIR}${PREFIX}/include/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgd.so.5
.include <bsd.port.mk>