aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-10-07 05:05:12 +0800
committerak <ak@FreeBSD.org>2012-10-07 05:05:12 +0800
commit60ef6f45497a19400ab7dbfb4bc05e3b44f083cd (patch)
tree5a6afda157f0c8740318b98995044361831ec8b0 /graphics
parentb3bc078aeb592c57a9b41cf17a1b1896120bffbb (diff)
downloadfreebsd-ports-gnome-60ef6f45497a19400ab7dbfb4bc05e3b44f083cd.tar.gz
freebsd-ports-gnome-60ef6f45497a19400ab7dbfb4bc05e3b44f083cd.tar.zst
freebsd-ports-gnome-60ef6f45497a19400ab7dbfb4bc05e3b44f083cd.zip
- Convert Makefile headers to new style
- Add DESKTOP_ENTRIES - Pass maintainership to nemysis <nemysis@gmx.ch> PR: ports/172342 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/eos-movrec/Makefile32
-rw-r--r--graphics/eos-movrec/distinfo4
2 files changed, 22 insertions, 14 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index 50f97f931635..a71b15ed6ef9 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -1,34 +1,42 @@
-# New ports collection makefile for: EOS camera movie record
-# Date created: 15 Aug 2011
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
# $FreeBSD$
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= eos-movrec
DISTVERSION= 0.3.1_beta
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A program to capture short movies with Canon DSLR camera
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Program to capture short movies with Canon DSLR camera
LICENSE= GPLv2
-LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2
+BUILD_DEPENDS= pnmtopng:${PORTSDIR}/graphics/netpbm
-USE_ZIP= yes
+USE_BZIP2= yes
USE_CMAKE= yes
+CMAKE_VERBOSE= yes
USE_QT4= qmake_build moc_build rcc_build uic_build gui
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
DISTVERSIONSUFFIX= -src
-PORTREVISION= 1
-PLIST_FILES= bin/eos_movrec
+PLIST_FILES= bin/eos_movrec \
+ share/pixmaps/${PORTNAME}.png
+
+DESKTOP_ENTRIES= "EOS Camera Movie Record" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME:S/-/_/}" "Application;Graphics;" ${FALSE}
post-patch:
@${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/os_api.h
+post-build:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/winicontoppm -bestqual eos-movrec2.ico | \
+ ${LOCALBASE}/bin/pnmtopng > eos-movrec.png)
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+
.include <bsd.port.mk>
diff --git a/graphics/eos-movrec/distinfo b/graphics/eos-movrec/distinfo
index b03d4bc02f2e..e5da54644ed2 100644
--- a/graphics/eos-movrec/distinfo
+++ b/graphics/eos-movrec/distinfo
@@ -1,2 +1,2 @@
-SHA256 (eos-movrec-0.3.1_beta-src.zip) = 25897e7d173d6baa0cfa94a8e0ff5f3decf809d2644ddf2a492677c068efc0c3
-SIZE (eos-movrec-0.3.1_beta-src.zip) = 5183470
+SHA256 (eos-movrec-0.3.1_beta-src.tar.bz2) = 044cf8b6428d66d6d03c3df53103f985e5b669cad3c8f78a94f9ef308259deea
+SIZE (eos-movrec-0.3.1_beta-src.tar.bz2) = 3955037