aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
commit6a2c8adf9eab2d622b7805a3cb7990c8c9454251 (patch)
treee2529c5247b78282bbb3a3cc3aaaad34e48baf86 /graphics
parentc9983b6ed69b31349559fe4008e6b2e88fe191c7 (diff)
downloadfreebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.gz
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.zst
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.zip
Try to bring some consistency to ports that have x86-specific pieces.
- in general, if we think that the code is not architecture-specific, and instead just enables x86 assembler by default, those should use BROKEN rather than IGNORE. This will allow them to be attempted with TRYBROKEN. - spell i386 as x86. - spell asm as assembler. - pet portlint. These changes should have no effect on tier-1 builds. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index cb1d46c9b7d6..ab6acbd8e990 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -18,8 +18,13 @@ LICENSE_FILE_CeCILL= ${WRKSRC}/Licence_CeCILL_V2-en.txt
LICENSE_PERMS_CeCILL_C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_CeCILL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= invokes i386 asm
+BROKEN_aarch64= invokes x86 assembler
+BROKEN_armv6= invokes x86 assembler
+BROKEN_armv7= invokes x86 assembler
+BROKEN_mips= invokes x86 assembler
+BROKEN_mips64= invokes x86 assembler
+BROKEN_sparc64= invokes x86 assembler
+BROKEN_powerpc64= invokes x86 assembler
USE_GITHUB= yes
GH_ACCOUNT= dtschump