aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2001-02-11 06:36:48 +0800
committerkris <kris@FreeBSD.org>2001-02-11 06:36:48 +0800
commit776b8703046bbd1cef95d42145a02d88d9a3bcbf (patch)
treeae740f1c2aefa9a30f726923a9e38d68bdc481c7 /graphics
parentaf5a1b02b327e7be8cb87ced1b4012c0c31e9065 (diff)
downloadfreebsd-ports-gnome-776b8703046bbd1cef95d42145a02d88d9a3bcbf.tar.gz
freebsd-ports-gnome-776b8703046bbd1cef95d42145a02d88d9a3bcbf.tar.zst
freebsd-ports-gnome-776b8703046bbd1cef95d42145a02d88d9a3bcbf.zip
Add an install-time warning about insecurity of this port - it has local
exploits yielding user uucp, but due to the nature of the software probably isn't going to be widely used on multi-user systems.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/camediaplay/Makefile5
-rw-r--r--graphics/camediaplay/pkg-install9
2 files changed, 14 insertions, 0 deletions
diff --git a/graphics/camediaplay/Makefile b/graphics/camediaplay/Makefile
index dc8e2c949309..104bbb635b21 100644
--- a/graphics/camediaplay/Makefile
+++ b/graphics/camediaplay/Makefile
@@ -19,6 +19,11 @@ MAN1= camediaplay.1
DOC= README.english README.japanese PROTOCOL
+pre-fetch:
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+ ${SH} pkg-install
+.endif
+
post-install:
${MKDIR} ${PREFIX}/share/doc/camediaplay
for i in ${DOC}; do \
diff --git a/graphics/camediaplay/pkg-install b/graphics/camediaplay/pkg-install
new file mode 100644
index 000000000000..564aa6f6de4b
--- /dev/null
+++ b/graphics/camediaplay/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+/usr/bin/dialog --yesno "SECURITY NOTE: This port is not safe to install on multi-user systems containing untrusted users - it is vulnerable to a local buffer overflow and format string vulnerability which allow an attacker to obtain access to the uucp user. Do you wish to proceed with the installation of the software anyway?" 9 70 || /usr/bin/false
+
+