aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-09 10:41:00 +0800
committerwg <wg@FreeBSD.org>2013-10-09 10:41:00 +0800
commit9069650ea7cde720a81a21247ea47eef97235da5 (patch)
tree91a6b18e3f4f27b73ec3d885dff32819991ec152 /graphics
parent06f24dcab4f59268220879553f08eb6ded3a24c2 (diff)
downloadfreebsd-ports-gnome-9069650ea7cde720a81a21247ea47eef97235da5.tar.gz
freebsd-ports-gnome-9069650ea7cde720a81a21247ea47eef97235da5.tar.zst
freebsd-ports-gnome-9069650ea7cde720a81a21247ea47eef97235da5.zip
graphics/php5-ffmpeg: link using ffmpeg0
- Link using ffmpeg0 - Convert lib depends to new format Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php5-ffmpeg/Makefile27
1 files changed, 23 insertions, 4 deletions
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 2e4c39551ae2..3044414ed70c 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.6.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}-php/${PORTNAME}-php/${PORTVERSION}
PKGNAMEPREFIX= php5-
@@ -13,19 +13,38 @@ EXTRACT_SUFX= .tbz2
MAINTAINER= acm@FreeBSD.org
COMMENT= The ffmpeg shared extension for php
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- avutil.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0
CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/ffmpeg0
USE_BZIP2= yes
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
-CONFIGURE_ARGS+= --with-ffmpeg=${LOCALBASE}/include
+CONFIGURE_ARGS+= --with-ffmpeg=${LOCALBASE}/include/ffmpeg0
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|==|=|g' ${WRKSRC}/config.m4
+ @${REINPLACE_CMD} \
+ -e 's,<avcodec\.h>,<libavcodec/avcodec\.h>,g' \
+ -e 's,<avformat\.h>,<libavformat/avformat\.h>,g' \
+ -e 's,<swscale\.h>,<libswscale/swscale\.h>,g' \
+ ${WRKSRC}/*.c \
+ ${WRKSRC}/*.h
+
+pre-configure:
+ @${REINPLACE_CMD} \
+ -e 's,lavcodec,lavcodec0,g' \
+ -e 's,lavformat,lavformat0,g' \
+ -e 's,lavutil,lavutil0,g' \
+ -e 's,lswscale,lswscale0,g' \
+ ${WRKSRC}/configure
+
+post-configure:
+ @${REINPLACE_CMD} -e 's,include/ffmpeg$$,include/ffmpeg0,g' \
+ ${WRKSRC}/Makefile
.include <bsd.port.mk>