aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-04-05 04:30:18 +0800
committerdanfe <danfe@FreeBSD.org>2014-04-05 04:30:18 +0800
commita0265dd5d775a91ee87b711f0e2373598d77834a (patch)
treed59d2f1862e82225463f4bd59b7d3ed464b9b8fc /graphics
parent6998a755a32a2a810ef29ddf0b3a176e14880d0c (diff)
downloadfreebsd-ports-gnome-a0265dd5d775a91ee87b711f0e2373598d77834a.tar.gz
freebsd-ports-gnome-a0265dd5d775a91ee87b711f0e2373598d77834a.tar.zst
freebsd-ports-gnome-a0265dd5d775a91ee87b711f0e2373598d77834a.zip
- Update to version 0.24, sort pkg-plist
- Define LICENSE (GPLv2), augment COMMENT - Provide more sensible port description Approved by: multimedia (bapt)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/exiv2/Makefile21
-rw-r--r--graphics/exiv2/distinfo4
-rw-r--r--graphics/exiv2/files/patch-src-Makefile8
-rw-r--r--graphics/exiv2/pkg-descr7
-rw-r--r--graphics/exiv2/pkg-plist12
5 files changed, 32 insertions, 20 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 5d0e9aa3153d..34817354663a 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -2,29 +2,34 @@
# $FreeBSD$
PORTNAME= exiv2
-PORTVERSION= 0.23
-PORTREVISION= 2
+PORTVERSION= 0.24
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= Exif and Iptc metadata manipulation library and tools
+COMMENT= Exif, IPTC, and XMP metadata manipulation library and tools
+
+LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-GNU_CONFIGURE= yes
USES= gettext gmake iconv libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-ALLTARGET= all
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's,LDFLAGS -no-undefined -lpsapi",& ;; \
+ dragonfly* | freebsd*),' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/src/Makefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/exiv2
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libexiv2.so.12
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/exiv2 \
+ ${STAGEDIR}${PREFIX}/lib/libexiv2.so.13
.include <bsd.port.mk>
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
index 0bef88e073ca..76265048025f 100644
--- a/graphics/exiv2/distinfo
+++ b/graphics/exiv2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (exiv2-0.23.tar.gz) = 81fa50900be7ab16e24c6551252c21fc97abcfe855fd32c8f7ec55f398786b11
-SIZE (exiv2-0.23.tar.gz) = 3524381
+SHA256 (exiv2-0.24.tar.gz) = f4a443e6c7fb9d9f5e787732f76969a64c72c4c04af69b10ed57f949c2dfef8e
+SIZE (exiv2-0.24.tar.gz) = 4635028
diff --git a/graphics/exiv2/files/patch-src-Makefile b/graphics/exiv2/files/patch-src-Makefile
index 6a943950f49f..5055cb1a184f 100644
--- a/graphics/exiv2/files/patch-src-Makefile
+++ b/graphics/exiv2/files/patch-src-Makefile
@@ -1,11 +1,11 @@
--- src/Makefile.orig
+++ src/Makefile
-@@ -249,7 +249,7 @@
- @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $@.o -rpath $(libdir)
+@@ -231,7 +231,7 @@ lib: $(OBJ)
$(EXIV2BIN): lib $(EXIV2OBJ) $(EXIV2COBJ)
+ -mkdir ../bin >/dev/null 2>&1
- @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir)
+ @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir) $(LIBS)
- $(MCBIN): lib $(MCOBJ)
- @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(MCOBJ) -rpath $(libdir)
+ install-header:
+ $(INSTALL_DIRS) $(DESTDIR)$(incdir)
diff --git a/graphics/exiv2/pkg-descr b/graphics/exiv2/pkg-descr
index 585bd729021c..2742c23100d3 100644
--- a/graphics/exiv2/pkg-descr
+++ b/graphics/exiv2/pkg-descr
@@ -1,3 +1,6 @@
-Exif and Iptc metadata manipulation library and tools
+Exiv2 is a C++ library and a command line utility to manage image metadata.
+It provides fast and easy read and write access to the Exif, IPTC, and XMP
+metadata of images in various formats. Exiv2 is available as free software
+and with a commercial license, and is used in many projects.
-WWW: http://www.exiv2.org/
+WWW: http://www.exiv2.org/
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index 611e2bac3694..fb7cd13b3abf 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -1,22 +1,24 @@
bin/exiv2
+include/exiv2/asfvideo.hpp
include/exiv2/basicio.hpp
include/exiv2/bmpimage.hpp
include/exiv2/convert.hpp
include/exiv2/cr2image.hpp
include/exiv2/crwimage.hpp
include/exiv2/datasets.hpp
-include/exiv2/error.hpp
include/exiv2/easyaccess.hpp
include/exiv2/epsimage.hpp
+include/exiv2/error.hpp
include/exiv2/exif.hpp
-include/exiv2/exv_conf.h
include/exiv2/exiv2.hpp
+include/exiv2/exv_conf.h
include/exiv2/futils.hpp
include/exiv2/gifimage.hpp
include/exiv2/image.hpp
include/exiv2/iptc.hpp
include/exiv2/jp2image.hpp
include/exiv2/jpgimage.hpp
+include/exiv2/matroskavideo.hpp
include/exiv2/metadatum.hpp
include/exiv2/mrwimage.hpp
include/exiv2/orfimage.hpp
@@ -25,7 +27,9 @@ include/exiv2/pngimage.hpp
include/exiv2/preview.hpp
include/exiv2/properties.hpp
include/exiv2/psdimage.hpp
+include/exiv2/quicktimevideo.hpp
include/exiv2/rafimage.hpp
+include/exiv2/riffvideo.hpp
include/exiv2/rw2image.hpp
include/exiv2/tags.hpp
include/exiv2/tgaimage.hpp
@@ -38,8 +42,8 @@ include/exiv2/xmpsidecar.hpp
lib/libexiv2.a
lib/libexiv2.la
lib/libexiv2.so
-lib/libexiv2.so.12
-lib/libexiv2.so.12.0.0
+lib/libexiv2.so.13
+lib/libexiv2.so.13.0.0
libdata/pkgconfig/exiv2.pc
man/man1/exiv2.1.gz
share/locale/de/LC_MESSAGES/exiv2.mo