aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-31 06:42:23 +0800
committermarcus <marcus@FreeBSD.org>2003-08-31 06:42:23 +0800
commitb40eb044f87247fd1fba0e669e27b023abc75104 (patch)
tree083120aa9d10b6b4eddbb8dd70d998abe647c9aa /graphics
parent107c052b7de2fb3425cee8571dcc3fa5915ba3fd (diff)
downloadfreebsd-ports-gnome-b40eb044f87247fd1fba0e669e27b023abc75104.tar.gz
freebsd-ports-gnome-b40eb044f87247fd1fba0e669e27b023abc75104.tar.zst
freebsd-ports-gnome-b40eb044f87247fd1fba0e669e27b023abc75104.zip
Fix a bug where gimp would crash on startup on -CURRENT because a translated
pointer was being free'd accidentally. Reported by: Fritz Heinrichmeyer <Fritz.Heinrichmeyer@fernuni-hagen.de> Pav Lucistnik <pav@oook.cz>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-app-devel/Makefile1
-rw-r--r--graphics/gimp-app-devel/files/patch-app_widgets_gimpitemfactory.c11
-rw-r--r--graphics/gimp-app/Makefile1
-rw-r--r--graphics/gimp-app/files/patch-app_widgets_gimpitemfactory.c11
-rw-r--r--graphics/gimp-devel/Makefile1
-rw-r--r--graphics/gimp-devel/files/patch-app_widgets_gimpitemfactory.c11
-rw-r--r--graphics/gimp/Makefile1
-rw-r--r--graphics/gimp/files/patch-app_widgets_gimpitemfactory.c11
-rw-r--r--graphics/gimpshop/Makefile1
-rw-r--r--graphics/gimpshop/files/patch-app_widgets_gimpitemfactory.c11
10 files changed, 60 insertions, 0 deletions
diff --git a/graphics/gimp-app-devel/Makefile b/graphics/gimp-app-devel/Makefile
index 3f0d7c69d26f..be54deefa3fd 100644
--- a/graphics/gimp-app-devel/Makefile
+++ b/graphics/gimp-app-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.19
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp-app-devel/files/patch-app_widgets_gimpitemfactory.c b/graphics/gimp-app-devel/files/patch-app_widgets_gimpitemfactory.c
new file mode 100644
index 000000000000..09f3680dd9fb
--- /dev/null
+++ b/graphics/gimp-app-devel/files/patch-app_widgets_gimpitemfactory.c
@@ -0,0 +1,11 @@
+--- app/widgets/gimpitemfactory.c.orig Sat Aug 30 16:19:07 2003
++++ app/widgets/gimpitemfactory.c Sat Aug 30 18:36:59 2003
+@@ -1036,7 +1036,7 @@
+ }
+ else
+ {
+- translation = dgettext (domain, full_path);
++ translation = g_strdup (dgettext (domain, full_path));
+ }
+
+ if (strncmp (item_factory->path, translation,
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 3f0d7c69d26f..be54deefa3fd 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.19
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp-app/files/patch-app_widgets_gimpitemfactory.c b/graphics/gimp-app/files/patch-app_widgets_gimpitemfactory.c
new file mode 100644
index 000000000000..09f3680dd9fb
--- /dev/null
+++ b/graphics/gimp-app/files/patch-app_widgets_gimpitemfactory.c
@@ -0,0 +1,11 @@
+--- app/widgets/gimpitemfactory.c.orig Sat Aug 30 16:19:07 2003
++++ app/widgets/gimpitemfactory.c Sat Aug 30 18:36:59 2003
+@@ -1036,7 +1036,7 @@
+ }
+ else
+ {
+- translation = dgettext (domain, full_path);
++ translation = g_strdup (dgettext (domain, full_path));
+ }
+
+ if (strncmp (item_factory->path, translation,
diff --git a/graphics/gimp-devel/Makefile b/graphics/gimp-devel/Makefile
index 3f0d7c69d26f..be54deefa3fd 100644
--- a/graphics/gimp-devel/Makefile
+++ b/graphics/gimp-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.19
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp-devel/files/patch-app_widgets_gimpitemfactory.c b/graphics/gimp-devel/files/patch-app_widgets_gimpitemfactory.c
new file mode 100644
index 000000000000..09f3680dd9fb
--- /dev/null
+++ b/graphics/gimp-devel/files/patch-app_widgets_gimpitemfactory.c
@@ -0,0 +1,11 @@
+--- app/widgets/gimpitemfactory.c.orig Sat Aug 30 16:19:07 2003
++++ app/widgets/gimpitemfactory.c Sat Aug 30 18:36:59 2003
+@@ -1036,7 +1036,7 @@
+ }
+ else
+ {
+- translation = dgettext (domain, full_path);
++ translation = g_strdup (dgettext (domain, full_path));
+ }
+
+ if (strncmp (item_factory->path, translation,
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index 3f0d7c69d26f..be54deefa3fd 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.19
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp/files/patch-app_widgets_gimpitemfactory.c b/graphics/gimp/files/patch-app_widgets_gimpitemfactory.c
new file mode 100644
index 000000000000..09f3680dd9fb
--- /dev/null
+++ b/graphics/gimp/files/patch-app_widgets_gimpitemfactory.c
@@ -0,0 +1,11 @@
+--- app/widgets/gimpitemfactory.c.orig Sat Aug 30 16:19:07 2003
++++ app/widgets/gimpitemfactory.c Sat Aug 30 18:36:59 2003
+@@ -1036,7 +1036,7 @@
+ }
+ else
+ {
+- translation = dgettext (domain, full_path);
++ translation = g_strdup (dgettext (domain, full_path));
+ }
+
+ if (strncmp (item_factory->path, translation,
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index 3f0d7c69d26f..be54deefa3fd 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.19
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimpshop/files/patch-app_widgets_gimpitemfactory.c b/graphics/gimpshop/files/patch-app_widgets_gimpitemfactory.c
new file mode 100644
index 000000000000..09f3680dd9fb
--- /dev/null
+++ b/graphics/gimpshop/files/patch-app_widgets_gimpitemfactory.c
@@ -0,0 +1,11 @@
+--- app/widgets/gimpitemfactory.c.orig Sat Aug 30 16:19:07 2003
++++ app/widgets/gimpitemfactory.c Sat Aug 30 18:36:59 2003
+@@ -1036,7 +1036,7 @@
+ }
+ else
+ {
+- translation = dgettext (domain, full_path);
++ translation = g_strdup (dgettext (domain, full_path));
+ }
+
+ if (strncmp (item_factory->path, translation,