aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
committermiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
commitb5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7 (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /graphics
parent4c148339a17778393b116c6e7051a9bc484e786a (diff)
downloadfreebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.gz
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.zst
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Diffstat (limited to 'graphics')
-rw-r--r--graphics/jdraw/Makefile10
-rw-r--r--graphics/tgif/Makefile20
2 files changed, 14 insertions, 16 deletions
diff --git a/graphics/jdraw/Makefile b/graphics/jdraw/Makefile
index fc71d4142bf1..deaad307b137 100644
--- a/graphics/jdraw/Makefile
+++ b/graphics/jdraw/Makefile
@@ -16,7 +16,9 @@ COMMENT= A pixel oriented graphics editor
NO_BUILD= yes
USE_JAVA= yes
-OPTIONS= PLASTIC3D "Use Plastic3DLook&Feel" on
+OPTIONS_DEFINE= PLASTIC3D
+OPTIONS_DEFAULT= PLASTIC3D
+PLASTIC3D_DESC= Use Plastic3DLook&Feel
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= ${PORTNAME}
@@ -29,12 +31,12 @@ do-install:
${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PLASTIC3D)
+.if ${PORT_OPTIONS:MPLASTIC3D}
PLASTIC3D= "-Dlf=\"com.jgoodies.looks.plastic.Plastic3DLookAndFeel\""
RUN_DEPENDS+= ${JAVAJARDIR}/looks.jar:${PORTSDIR}/devel/looks
.endif
JAVA_VERSION= 1.6+
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/tgif/Makefile b/graphics/tgif/Makefile
index aead77ddd840..c5964ed64e33 100644
--- a/graphics/tgif/Makefile
+++ b/graphics/tgif/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tgif
-# Date created: 30 Jan 1999
-# Whom: bmc@WillsCreek.COM
-#
+# Created by: bmc@WillsCreek.COM
# $FreeBSD$
-#
PORTNAME= tgif
PORTVERSION= 4.2.2
@@ -19,8 +15,8 @@ COMMENT= An Xlib-based two-dimensional drawing tool and hyper-object browser
RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm
-OPTIONS= NLS "Enable native language support" on \
- A4SIZE "Set default paper size to A4" off
+OPTIONS_DEFINE= NLS A4SIZE DOCS
+A4SIZE_DESC= Set default paper size to A4
USE_GCC= any
USE_IMAKE= yes
@@ -31,16 +27,16 @@ CFLAGS+= ${PTHREAD_CFLAGS}
MAN1= tgif.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
IMAKEDEFINES+= WITH_NLS
PLIST_SUB= NLS=""
.else
PLIST_SUB= NLS="@comment "
.endif
-.if defined(WITH_A4SIZE)
+.if ${PORT_OPTIONS:MA4SIZE}
IMAKEDEFINES+= WITH_A4SIZE
.endif
@@ -65,9 +61,9 @@ post-install:
cd ${WRKSRC}/${D:S/demo//} \
&& ${INSTALL_DATA} ${EXAMPLES.${D}} ${EXAMPLESDIR}/${D}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>