aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-29 06:14:07 +0800
committerkrion <krion@FreeBSD.org>2003-10-29 06:14:07 +0800
commitbbe803a11e5cd38aeaa8c92bcc0c1884b69c565f (patch)
tree1be53e00bb04178434c514dded5e6b0bda975042 /graphics
parent6b50d4f5bca698a5a640cce48994d6fb3d0a562b (diff)
downloadfreebsd-ports-gnome-bbe803a11e5cd38aeaa8c92bcc0c1884b69c565f.tar.gz
freebsd-ports-gnome-bbe803a11e5cd38aeaa8c92bcc0c1884b69c565f.tar.zst
freebsd-ports-gnome-bbe803a11e5cd38aeaa8c92bcc0c1884b69c565f.zip
- Update to version 2.1.3
PR: 58627 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgphoto2/Makefile18
-rw-r--r--graphics/libgphoto2/distinfo2
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:canon.c20
-rw-r--r--graphics/libgphoto2/files/patch-camlibs:canon:canon.h16
-rw-r--r--graphics/libgphoto2/pkg-plist124
5 files changed, 92 insertions, 88 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index b7624cbc90f6..041cd7f1d569 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libgphoto2
-PORTVERSION= 2.1.2
-PORTREVISION= 2
+PORTVERSION= 2.1.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
@@ -20,28 +19,29 @@ LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
exif.10:${PORTSDIR}/graphics/libexif
USE_BZIP2= yes
-USE_REINPLACE= yes
USE_GNOME= gnometarget pkgconfig
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+PLIST_SUB= VERSION=${PORTVERSION}
MAN3= libgphoto2.3 libgphoto2_port.3
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-patch:
.for file in configure libgphoto2_port/configure
@${REINPLACE_CMD} -e \
- 's|[{]libdir[}]/pkgconfig|{prefix}/libdata/pkgconfig|g ; \
+ 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|g ; \
s|-g ||g' ${WRKSRC}/${file}
.endfor
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|po packaging doc|po doc|g ; \
s|: install-docDATA|:|g'
- @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|<malloc\.h>|<stdlib.h>|g'
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/libgphoto2/distinfo b/graphics/libgphoto2/distinfo
index feeca2e0d2b2..31a93eb01fc2 100644
--- a/graphics/libgphoto2/distinfo
+++ b/graphics/libgphoto2/distinfo
@@ -1 +1 @@
-MD5 (libgphoto2-2.1.2.tar.bz2) = ded0d8262d02e4c215ffc0d73d5acbbb
+MD5 (libgphoto2-2.1.3.tar.bz2) = af200308629fcbe0b88d3802bba04779
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:canon.c b/graphics/libgphoto2/files/patch-camlibs:canon:canon.c
index 7ff5c82bbbbd..af1f64583bdd 100644
--- a/graphics/libgphoto2/files/patch-camlibs:canon:canon.c
+++ b/graphics/libgphoto2/files/patch-camlibs:canon:canon.c
@@ -1,17 +1,17 @@
---- camlibs/canon/canon.c.orig Sun Aug 10 20:51:13 2003
-+++ camlibs/canon/canon.c Mon Oct 20 10:17:48 2003
-@@ -138,6 +138,8 @@
+--- camlibs/canon/canon.c.orig Mon Oct 20 01:53:12 2003
++++ camlibs/canon/canon.c Sun Oct 26 22:55:34 2003
+@@ -147,6 +147,8 @@
/* 0x306D is S45 in PTP mode */
- {"Canon:PowerShot G3 (normal mode)", CANON_PS_G3, 0x04A9, 0x306E, CAP_SUP, S99M, S32K, NULL},
+ {"Canon:PowerShot G3 (normal mode)", CANON_PS_G3, 0x04A9, 0x306E, CAP_SUP, S99M, S32K, S2M, NULL},
/* 0x306F is G3 in PTP mode */
-+ {"Canon:PowerShot G5 (normal mode)", CANON_PS_G5, 0x04A9, 0x3085, CAP_SUP, S99M, S32K, NULL},
++ {"Canon:PowerShot G5 (normal mode)", CANON_PS_G5, 0x04A9, 0x3085, CAP_SUP, S99M, S32K, S2M, NULL},
+ /* XXX 0x???? is G5 in PTP mode */
- {"Canon:PowerShot S230 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, NULL},
- /* 0x3071 is S230 in PTP mode */
- {"Canon:Digital IXUS v3 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, NULL},
-@@ -250,6 +252,7 @@
- case CANON_PS_S40:
+ {"Canon:PowerShot S230 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, S2M, NULL},
+ {"Canon:Digital IXUS v3 (normal mode)", CANON_PS_S230, 0x04A9, 0x3070, CAP_SUP, S99M, S32K, S2M, NULL},
+ /* 0x3071 is S230/IXUS v3 in PTP mode */
+@@ -312,6 +314,7 @@
case CANON_PS_S45:
+ case CANON_PS_S400:
case CANON_PS_G3:
+ case CANON_PS_G5:
break;
diff --git a/graphics/libgphoto2/files/patch-camlibs:canon:canon.h b/graphics/libgphoto2/files/patch-camlibs:canon:canon.h
index af1dd957ef1f..852421e4ad99 100644
--- a/graphics/libgphoto2/files/patch-camlibs:canon:canon.h
+++ b/graphics/libgphoto2/files/patch-camlibs:canon:canon.h
@@ -1,18 +1,18 @@
---- camlibs/canon/canon.h.orig Sun Aug 10 20:51:13 2003
-+++ camlibs/canon/canon.h Mon Oct 20 10:17:51 2003
-@@ -86,6 +86,7 @@
+--- camlibs/canon/canon.h.orig Mon Oct 20 01:53:12 2003
++++ camlibs/canon/canon.h Sun Oct 26 22:57:54 2003
+@@ -87,6 +87,7 @@
* @CANON_PS_S330: Digital IXUS 330
* @CANON_PS_S45: PowerShot S45
* @CANON_PS_G3: PowerShot G3
-+ * @CANON_PS_G5: PowerShot G5
++ * @CANON_PS_G3: PowerShot G5
* @CANON_PS_S230: PowerShot S230, Digital IXUS v3
* @CANON_PS_A60: PowerShot A60
- * @CANON_EOS_10D: EOS 10D
-@@ -123,6 +124,7 @@
- CANON_PS_A300,
+ * @CANON_MV630I: MV630i camcorder
+@@ -133,6 +134,7 @@
+ CANON_PS_S50,
CANON_PS_S45,
CANON_PS_G3,
+ CANON_PS_G5,
- CANON_PS_S50,
CANON_PS_S230,
+ CANON_MV630I,
CANON_EOS_10D,
diff --git a/graphics/libgphoto2/pkg-plist b/graphics/libgphoto2/pkg-plist
index 45d4b835dd66..a850af135970 100644
--- a/graphics/libgphoto2/pkg-plist
+++ b/graphics/libgphoto2/pkg-plist
@@ -18,73 +18,75 @@ include/gphoto2/gphoto2-setting.h
include/gphoto2/gphoto2-version.h
include/gphoto2/gphoto2-widget.h
include/gphoto2/gphoto2.h
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_agfa_cl20.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_barbie.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_canon.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_casio_qv.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_digita.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_dimera3500.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_directory.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_fuji.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_gsmart300.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_jamcam.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_jd11.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_kodak_dc120.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_kodak_dc210.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_kodak_dc240.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_kodak_dc3200.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_konica.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_konica_qm150.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_largan.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_dimagev.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_mustek.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_panasonic_coolshot.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_panasonic_l859.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_panasonic_dc1000.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_panasonic_dc1580.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_pccam300.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_pccam600.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_polaroid_pdc320.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_polaroid_pdc640.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_polaroid_pdc700.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_ptp2.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_ricoh.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_samsung.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sierra.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sipix_blink.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sipix_blink2.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sipix_web2.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_smal.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sony_dscf1.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sony_dscf55.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_soundvision.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_spca50x.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sq905.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_stv0674.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_stv0680.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_sx330z.so
-lib/gphoto2/%%PORTVERSION%%/libgphoto2_toshiba.so
+lib/gphoto2/%%VERSION%%/libgphoto2_agfa_cl20.so
+lib/gphoto2/%%VERSION%%/libgphoto2_barbie.so
+lib/gphoto2/%%VERSION%%/libgphoto2_canon.so
+lib/gphoto2/%%VERSION%%/libgphoto2_casio_qv.so
+lib/gphoto2/%%VERSION%%/libgphoto2_digita.so
+lib/gphoto2/%%VERSION%%/libgphoto2_dimagev.so
+lib/gphoto2/%%VERSION%%/libgphoto2_dimera3500.so
+lib/gphoto2/%%VERSION%%/libgphoto2_directory.so
+lib/gphoto2/%%VERSION%%/libgphoto2_fuji.so
+lib/gphoto2/%%VERSION%%/libgphoto2_gsmart300.so
+lib/gphoto2/%%VERSION%%/libgphoto2_jamcam.so
+lib/gphoto2/%%VERSION%%/libgphoto2_jd11.so
+lib/gphoto2/%%VERSION%%/libgphoto2_kodak_dc120.so
+lib/gphoto2/%%VERSION%%/libgphoto2_kodak_dc210.so
+lib/gphoto2/%%VERSION%%/libgphoto2_kodak_dc240.so
+lib/gphoto2/%%VERSION%%/libgphoto2_kodak_dc3200.so
+lib/gphoto2/%%VERSION%%/libgphoto2_konica.so
+lib/gphoto2/%%VERSION%%/libgphoto2_konica_qm150.so
+lib/gphoto2/%%VERSION%%/libgphoto2_largan.so
+lib/gphoto2/%%VERSION%%/libgphoto2_mustek.so
+lib/gphoto2/%%VERSION%%/libgphoto2_panasonic_coolshot.so
+lib/gphoto2/%%VERSION%%/libgphoto2_panasonic_dc1000.so
+lib/gphoto2/%%VERSION%%/libgphoto2_panasonic_dc1580.so
+lib/gphoto2/%%VERSION%%/libgphoto2_panasonic_l859.so
+lib/gphoto2/%%VERSION%%/libgphoto2_pccam300.so
+lib/gphoto2/%%VERSION%%/libgphoto2_pccam600.so
+lib/gphoto2/%%VERSION%%/libgphoto2_polaroid_pdc320.so
+lib/gphoto2/%%VERSION%%/libgphoto2_polaroid_pdc640.so
+lib/gphoto2/%%VERSION%%/libgphoto2_polaroid_pdc700.so
+lib/gphoto2/%%VERSION%%/libgphoto2_ptp2.so
+lib/gphoto2/%%VERSION%%/libgphoto2_ricoh.so
+lib/gphoto2/%%VERSION%%/libgphoto2_ricoh_g3.so
+lib/gphoto2/%%VERSION%%/libgphoto2_samsung.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sierra.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sipix_blink.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sipix_blink2.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sipix_web2.so
+lib/gphoto2/%%VERSION%%/libgphoto2_smal.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sony_dscf1.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sony_dscf55.so
+lib/gphoto2/%%VERSION%%/libgphoto2_soundvision.so
+lib/gphoto2/%%VERSION%%/libgphoto2_spca50x.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sq905.so
+lib/gphoto2/%%VERSION%%/libgphoto2_stv0674.so
+lib/gphoto2/%%VERSION%%/libgphoto2_stv0680.so
+lib/gphoto2/%%VERSION%%/libgphoto2_sx330z.so
+lib/gphoto2/%%VERSION%%/libgphoto2_toshiba.so
lib/gphoto2_port/0.5.1/libgphoto2_port_serial.so
lib/gphoto2_port/0.5.1/libgphoto2_port_usb.so
-libdata/pkgconfig/libgphoto2.pc
lib/libgphoto2.a
lib/libgphoto2.so
lib/libgphoto2.so.2
lib/libgphoto2_port.a
lib/libgphoto2_port.so
lib/libgphoto2_port.so.5
-%%PORTDOCS%%share/doc/libgphoto2/AUTHORS
-%%PORTDOCS%%share/doc/libgphoto2/NEWS
-%%PORTDOCS%%share/doc/libgphoto2/README
+libdata/pkgconfig/libgphoto2.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%share/doc/libgphoto2_port/AUTHORS
%%PORTDOCS%%share/doc/libgphoto2_port/NEWS
%%PORTDOCS%%share/doc/libgphoto2_port/README
-share/libgphoto2/%%PORTVERSION%%/konica/english
-share/libgphoto2/%%PORTVERSION%%/konica/french
-share/libgphoto2/%%PORTVERSION%%/konica/german
-share/libgphoto2/%%PORTVERSION%%/konica/japanese
-share/libgphoto2/%%PORTVERSION%%/konica/korean
-share/libgphoto2/%%PORTVERSION%%/konica/spanish
+share/libgphoto2/%%VERSION%%/konica/english
+share/libgphoto2/%%VERSION%%/konica/french
+share/libgphoto2/%%VERSION%%/konica/german
+share/libgphoto2/%%VERSION%%/konica/japanese
+share/libgphoto2/%%VERSION%%/konica/korean
+share/libgphoto2/%%VERSION%%/konica/spanish
+share/locale/cs/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/da/LC_MESSAGES/libgphoto2-2.mo
share/locale/da/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/de/LC_MESSAGES/libgphoto2-2.mo
@@ -93,12 +95,14 @@ share/locale/es/LC_MESSAGES/libgphoto2-2.mo
share/locale/es/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/fr/LC_MESSAGES/libgphoto2-2.mo
share/locale/fr/LC_MESSAGES/libgphoto2_port-0.mo
+share/locale/hu/LC_MESSAGES/libgphoto2-2.mo
share/locale/it/LC_MESSAGES/libgphoto2-2.mo
share/locale/it/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/ja/LC_MESSAGES/libgphoto2-2.mo
share/locale/ja/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/no/LC_MESSAGES/libgphoto2-2.mo
share/locale/no/LC_MESSAGES/libgphoto2_port-0.mo
+share/locale/pt_BR/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/ru/LC_MESSAGES/libgphoto2-2.mo
share/locale/ru/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/sl/LC_MESSAGES/libgphoto2-2.mo
@@ -109,13 +113,13 @@ share/locale/uk/LC_MESSAGES/libgphoto2-2.mo
share/locale/uk/LC_MESSAGES/libgphoto2_port-0.mo
share/locale/zh_CN/LC_MESSAGES/libgphoto2-2.mo
share/locale/zh_CN/LC_MESSAGES/libgphoto2_port-0.mo
-@dirrm share/libgphoto2/%%PORTVERSION%%/konica
-@dirrm share/libgphoto2/%%PORTVERSION%%
+@dirrm share/libgphoto2/%%VERSION%%/konica
+@dirrm share/libgphoto2/%%VERSION%%
@dirrm share/libgphoto2
%%PORTDOCS%%@dirrm share/doc/libgphoto2_port
-%%PORTDOCS%%@dirrm share/doc/libgphoto2
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/gphoto2_port/0.5.1
@dirrm lib/gphoto2_port
-@dirrm lib/gphoto2/%%PORTVERSION%%
+@dirrm lib/gphoto2/%%VERSION%%
@dirrm lib/gphoto2
@dirrm include/gphoto2