aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2014-10-11 22:57:48 +0800
committerwen <wen@FreeBSD.org>2014-10-11 22:57:48 +0800
commitbe567fe23dd4c211300b6ff6583ac516ab2ee831 (patch)
tree18fde4716097c67209bb2ee07147790bbc74863a /graphics
parentb8de34e5209fe5cf083b56aebb209e4da2cb613f (diff)
downloadfreebsd-ports-gnome-be567fe23dd4c211300b6ff6583ac516ab2ee831.tar.gz
freebsd-ports-gnome-be567fe23dd4c211300b6ff6583ac516ab2ee831.tar.zst
freebsd-ports-gnome-be567fe23dd4c211300b6ff6583ac516ab2ee831.zip
- Pass correct value to configure with WMS_CLIENT and WFS_CLIENT option
PR: 194266 Submitted by: Julien Cigar<jcigar@ulb.ac.be>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapserver/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index c723c2eafa83..b2ed7f654cda 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -39,7 +39,7 @@ WCS_DESC= WCS Server support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
+USES+= python:2
BUILD_DEPENDS+= swig2.0:${PORTSDIR}/devel/swig20
CMAKE_ARGS+= -DWITH_PYTHON=yes
PLIST_SUB+= PYTHON=""
@@ -115,7 +115,7 @@ CMAKE_ARGS+= -DWITH_GEOS=0
.endif
.if ${PORT_OPTIONS:MPOSTGIS}
-USE_PGSQL= yes
+USES+= pgsql
CMAKE_ARGS+= -DWITH_POSTGIS=1
.else
CMAKE_ARGS+= -DWITH_POSTGIS=0
@@ -169,13 +169,13 @@ PROG_FILES= legend scalebar shp2img shptree shptreetst shptreevis \
.if ${PORT_OPTIONS:MCLIENT_WMS}
LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
LIB_DEPENDS+= libgdal.so:${PORTSDIR}/graphics/gdal
-CMAKE_ARGS+= -DWITH_CURL=1 -DGDAL=1 -DCLIENT_WMS=1
+CMAKE_ARGS+= -DWITH_CURL=1 -DWITH_GDAL=1 -DWITH_CLIENT_WMS=1
.endif
.if ${PORT_OPTIONS:MCLIENT_WFS}
LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
LIB_DEPENDS+= libgdal.so:${PORTSDIR}/graphics/gdal
-CMAKE_ARGS+= -DWITH_CURL=1 -DGDAL=1 -DCLIENT_WFS=1
+CMAKE_ARGS+= -DWITH_CURL=1 -DWITH_GDAL=1 -DWITH_CLIENT_WFS=1
.endif
do-install: