aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-02-11 10:26:25 +0800
committerdougb <dougb@FreeBSD.org>2002-02-11 10:26:25 +0800
commitbfb665806c207e2dd5c3015c1177eeb2fe7ce82e (patch)
tree9f94c1b20c8ae22fa3589a370d450e7673c7d7fa /graphics
parentfb2fd7a11233068e074ac062529cfabee7224ccb (diff)
downloadfreebsd-ports-gnome-bfb665806c207e2dd5c3015c1177eeb2fe7ce82e.tar.gz
freebsd-ports-gnome-bfb665806c207e2dd5c3015c1177eeb2fe7ce82e.tar.zst
freebsd-ports-gnome-bfb665806c207e2dd5c3015c1177eeb2fe7ce82e.zip
No response from Chuck, no response from anyone else on ports, so I'm
going to take this one over for now. Chuck hasn't logged into freefall since August, and this port has been unfetchable since October. This update makes the port fetchable, and the new version builds and runs. The next step for those intrested in non-English language support would be to create slave ports which bring in the new xpdf modules. I haven't incorporated all of the parts of the PR, since I don't understand what the originator is driving at, and I want to get this port back on the air. I'll ask for some feedback on the PR. If anyone with more experience/interest in this port wants to take it over, just shoot me an e-mail. PR: ports/34770 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpdf/Makefile17
-rw-r--r--graphics/xpdf/distinfo3
-rw-r--r--graphics/xpdf/files/patch-aa6
-rw-r--r--graphics/xpdf/files/patch-ab8
-rw-r--r--graphics/xpdf/pkg-descr1
-rw-r--r--graphics/xpdf/pkg-plist2
6 files changed, 16 insertions, 21 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 0f13ae2b5309..17934b790901 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -6,29 +6,22 @@
#
PORTNAME= xpdf
-PORTVERSION= 0.92
+PORTVERSION= 1.00
CATEGORIES= graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/xpdf
-EXTRACT_SUFX= .tgz
-PATCH_SITES= http://vzzbx.xs4all.nl/files/ \
- http://www.cs.cmu.edu/~dst/Adobe/Gallery/
-PATCHFILES= xpdf-ro-remove.patch
-PATCH_DIST_STRIP= -p1
-
-MAINTAINER= chuckr@FreeBSD.org
+MAINTAINER= DougB@FreeBSD.org
LIB_DEPENDS= t1.4:${PORTSDIR}/devel/t1lib
+USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_FREETYPE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS= --with-gzip --enable-opi \
- --enable-japanese \
- --enable-chinese-cns --enable-chinese-gb \
--with-t1-library=${LOCALBASE}/lib \
--with-t1-includes=${LOCALBASE}/include \
--with-freetype-library=${LOCALBASE}/lib \
@@ -37,11 +30,13 @@ CONFIGURE_ARGS= --with-gzip --enable-opi \
CONFIGURE_ARGS+= --enable-a4-paper
.endif
-MAN1= pdfimages.1 \
+MAN1= pdffonts.1 \
+ pdfimages.1 \
pdfinfo.1 \
pdftopbm.1 \
pdftops.1 \
pdftotext.1 \
xpdf.1
+MAN5= xpdfrc.5
.include <bsd.port.mk>
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf/distinfo
index 7f7f59eea192..4cb9cfef3138 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf/distinfo
@@ -1,2 +1 @@
-MD5 (xpdf-0.92.tgz) = 2d6e9fb157db928bd0cca4214ddd2c80
-MD5 (xpdf-ro-remove.patch) = cd4717d3de8244bbcd04d11114b73e57
+MD5 (xpdf-1.00.tar.gz) = 81f3c381cef729e4b6f4ce21cf5bbf3c
diff --git a/graphics/xpdf/files/patch-aa b/graphics/xpdf/files/patch-aa
index dd9da126dbb0..9eb2e67d6f80 100644
--- a/graphics/xpdf/files/patch-aa
+++ b/graphics/xpdf/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Dec 4 13:28:07 2000
-+++ configure.in Thu Jan 11 21:05:07 2001
-@@ -183,6 +183,16 @@
+--- configure.in.orig Fri Feb 1 15:15:45 2002
++++ configure.in Sun Feb 10 17:42:52 2002
+@@ -193,6 +193,16 @@
if test "$xpdf_cv_func_mkstemp" = yes; then
AC_DEFINE(HAVE_MKSTEMP)
fi
diff --git a/graphics/xpdf/files/patch-ab b/graphics/xpdf/files/patch-ab
index 6054622530ce..097cc6faa99f 100644
--- a/graphics/xpdf/files/patch-ab
+++ b/graphics/xpdf/files/patch-ab
@@ -1,6 +1,6 @@
---- goo/gfile.cc.org Fri Sep 1 14:35:26 2000
-+++ goo/gfile.cc Fri Sep 1 14:17:34 2000
-@@ -468,6 +468,16 @@
+--- goo/gfile.cc.orig Fri Feb 1 15:15:45 2002
++++ goo/gfile.cc Sun Feb 10 17:42:52 2002
+@@ -489,6 +489,16 @@
int fd;
if (ext) {
@@ -17,7 +17,7 @@
if (!(s = tmpnam(NULL))) {
return gFalse;
}
-@@ -478,6 +488,7 @@
+@@ -499,6 +509,7 @@
}
(*name)->append(ext);
fd = open((*name)->getCString(), O_WRONLY | O_CREAT | O_EXCL, 0600);
diff --git a/graphics/xpdf/pkg-descr b/graphics/xpdf/pkg-descr
index 97d00f621c5b..c27e12e090d5 100644
--- a/graphics/xpdf/pkg-descr
+++ b/graphics/xpdf/pkg-descr
@@ -7,4 +7,3 @@ or Xt libraries. It uses standard X fonts. Xpdf is quite usable on a
486-66 PC running FreeBSD.
WWW: http://www.foolabs.com/xpdf/
- http://www.cs.cmu.edu/~dst/Adobe/Gallery/
diff --git a/graphics/xpdf/pkg-plist b/graphics/xpdf/pkg-plist
index 11427e76f6ea..71ffba4a7afd 100644
--- a/graphics/xpdf/pkg-plist
+++ b/graphics/xpdf/pkg-plist
@@ -1,6 +1,8 @@
+bin/pdffonts
bin/pdfimages
bin/pdfinfo
bin/pdftopbm
bin/pdftops
bin/pdftotext
bin/xpdf
+etc/xpdfrc