aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-03-16 03:31:01 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-03-16 03:31:01 +0800
commitcc0a4395bcf54351b0da9c956c541158e28fe27d (patch)
treef388ca64143363240e21611a628f80ad63df1774 /graphics
parent23d1f9ba121ca06637b62ebf3ae08318e1d5ea67 (diff)
downloadfreebsd-ports-gnome-cc0a4395bcf54351b0da9c956c541158e28fe27d.tar.gz
freebsd-ports-gnome-cc0a4395bcf54351b0da9c956c541158e28fe27d.tar.zst
freebsd-ports-gnome-cc0a4395bcf54351b0da9c956c541158e28fe27d.zip
Fix recursive STAGEDIR referencing.
This was fixed after initial commit in bsd.ocaml.mk r349286. ===> Checking for items in STAGEDIR missing from pkg-plist Error: Orphaned: @dir /wrkdirs/usr/ports/graphics/ocaml-images/work/stage/usr/local/%%OCAML_SITELIBDIR%% Error: Orphaned: @dir /wrkdirs/usr/ports/graphics/ocaml-images/work/stage/usr/local/lib/ocaml Error: Orphaned: @dir /wrkdirs/usr/ports/graphics/ocaml-images/work/stage/usr/local/lib ...
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ocaml-images/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 5fcfe69afad4..c5128fcace44 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -3,7 +3,7 @@
PORTNAME= images
PORTVERSION= 4.0.1
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/camlspotter/camlimages/get/
@@ -19,7 +19,6 @@ BUILD_DEPENDS+= omake:devel/omake
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
-OCAMLFIND_DESTDIR= ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}
OCAML_PKGDIRS= camlimages
OCAML_LDLIBS= ${OCAML_SITELIBDIR}/camlimages
@@ -77,10 +76,6 @@ do-configure:
do-build:
(cd ${WRKSRC} && ${OMAKE} ${OMARGS})
-ocaml-findlib:
- # Overriding ocaml-findlib target which does not support stage
- # The consequence is that pkg-plist must be manually supported
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${OCAML_LDLIBS}
(cd ${WRKSRC} && ${OMAKE} ${OMARGS} install)