aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 02:58:49 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 02:58:49 +0800
commitccba16b77d253e5ffd5096d104eae3547a03a65a (patch)
tree260d32ac0834abda29aa562651c9bd0c9145b87c /graphics
parente929a8175cd3dc443cd91770c132baf706e0b1ed (diff)
downloadfreebsd-ports-gnome-ccba16b77d253e5ffd5096d104eae3547a03a65a.tar.gz
freebsd-ports-gnome-ccba16b77d253e5ffd5096d104eae3547a03a65a.tar.zst
freebsd-ports-gnome-ccba16b77d253e5ffd5096d104eae3547a03a65a.zip
- fix MASTER_SITES
- use DOCSDIR - fix the auto* build PR: 52135 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Hermes/Makefile22
-rw-r--r--graphics/Hermes/distinfo2
-rw-r--r--graphics/Hermes/files/patch-configure10
3 files changed, 27 insertions, 7 deletions
diff --git a/graphics/Hermes/Makefile b/graphics/Hermes/Makefile
index 5727bbf1cbb4..070460dd1ad3 100644
--- a/graphics/Hermes/Makefile
+++ b/graphics/Hermes/Makefile
@@ -8,27 +8,37 @@
PORTNAME= Hermes
PORTVERSION= 1.3.2
CATEGORIES= graphics
-MASTER_SITES= http://dark.x.dtu.dk/~mbn/clanlib/download/
+MASTER_SITES= http://www.clanlib.org/download/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast pixel formats conversion library
+BUILD_DEPENDS= ${LOCALBASE}/share/automake/depcomp:${PORTSDIR}/devel/automake
+
ONLY_FOR_ARCHS= i386 alpha
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
INSTALLS_SHLIB= yes
+pre-configure:
+ @${CP} ${LOCALBASE}/share/automake/depcomp ${WRKSRC}
+
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/Hermes
+ @${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog FAQ README TODO TODO.conversion
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/Hermes
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
- @${MKDIR} ${PREFIX}/share/doc/Hermes/API
+ @${MKDIR} ${DOCSDIR}/API
.for file in api-1.htm api-2.htm api-3.htm api-4.htm api.htm api.ps api.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/api/${file} ${PREFIX}/share/doc/Hermes/API
+ ${INSTALL_DATA} ${WRKSRC}/docs/api/${file} ${DOCSDIR}/API
.endfor
- ${INSTALL_DATA} ${WRKSRC}/docs/api/sgml/api.sgml ${PREFIX}/share/doc/Hermes/API
+ ${INSTALL_DATA} ${WRKSRC}/docs/api/sgml/api.sgml ${DOCSDIR}/API
.endif
.include <bsd.port.mk>
diff --git a/graphics/Hermes/distinfo b/graphics/Hermes/distinfo
index c5aafb9cf4d9..1474ef5a261b 100644
--- a/graphics/Hermes/distinfo
+++ b/graphics/Hermes/distinfo
@@ -1 +1 @@
-MD5 (Hermes-1.3.2.tar.gz) = 85432c0d0a8d983bb2be24e8d84d74b8
+MD5 (Hermes-1.3.2.tar.bz2) = 772db12a6e9c04b895913fd9f01b65fc
diff --git a/graphics/Hermes/files/patch-configure b/graphics/Hermes/files/patch-configure
new file mode 100644
index 000000000000..9703106d38d9
--- /dev/null
+++ b/graphics/Hermes/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Mon Mar 17 03:36:28 2003
++++ configure Mon May 12 16:27:09 2003
+@@ -7766,6 +7766,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'