aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-11-16 00:35:43 +0800
committergahr <gahr@FreeBSD.org>2011-11-16 00:35:43 +0800
commitdcbdf60130d199f5f9b9b6aa3b0efdc92c4b87d8 (patch)
tree904b1f3e8c11a855ca734b87ca6d05ba5b6681c3 /graphics
parent24b950b3bed212c3afd919a479b3c7021ca9b5fd (diff)
downloadfreebsd-ports-gnome-dcbdf60130d199f5f9b9b6aa3b0efdc92c4b87d8.tar.gz
freebsd-ports-gnome-dcbdf60130d199f5f9b9b6aa3b0efdc92c4b87d8.tar.zst
freebsd-ports-gnome-dcbdf60130d199f5f9b9b6aa3b0efdc92c4b87d8.zip
- Unbreak - fix build with latest x11-toolkits/fltk
Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cinepaint/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 912c36e61967..1af947b41ed0 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -29,8 +29,6 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_XORG= xpm
-BROKEN= does not compile
-
MAN1= cinepaint.1 cinepainttool.1
PLIST_SUB= VER=${PORTVERSION}-1
@@ -69,4 +67,8 @@ post-patch:
's|static GDrawableType|static GImageType|' \
${WRKSRC}/plug-ins/psd/psd.c
+ @${FIND} ${WRKSRC} -type f -name "*.c" -o -name "*.cpp" -o -name "*.cxx" -o -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; /^#include "FL/s|.h"$$|.H"|; \
+ s|fl_file_chooser.H|Fl_File_Chooser.H|g; s|#include <Fl|#include <FL|g; s|<FL/gl.H>|<FL/gl.h>|'
+
.include <bsd.port.post.mk>