aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-05-08 19:59:05 +0800
committertg <tg@FreeBSD.org>2001-05-08 19:59:05 +0800
commitdccb1ef571c67e8cb1b04d3b082ec55ff8891775 (patch)
tree10af0b216a27c9d6601075117980d344da5d68e7 /graphics
parentda06353c19204cca24b7b2cb4a3c1fd18ba2d6ef (diff)
downloadfreebsd-ports-gnome-dccb1ef571c67e8cb1b04d3b082ec55ff8891775.tar.gz
freebsd-ports-gnome-dccb1ef571c67e8cb1b04d3b082ec55ff8891775.tar.zst
freebsd-ports-gnome-dccb1ef571c67e8cb1b04d3b082ec55ff8891775.zip
Add PTHREAD_{CFLAGS,LIBS} to CFLAGS and LDFLAGS for XFree86-4.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opendx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index e47702e9397f..f3bb1179bb61 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -34,10 +34,17 @@ CONFIGURE_ENV= ARCH="" \
CFLAGS="${CFLAGS} -I${PREFIX}/include" \
CPPFLAGS="-I${PREFIX}/include" \
CXXFLAGS="${CFLAGS} -I${PREFIX}/include" \
- LDFLAGS="-L${PREFIX}/lib"
+ LDFLAGS="-L${PREFIX}/lib ${LDFLAGS}"
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} >= 4
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+.endif
+
post-patch:
@find ${WRKSRC} -name Makefile.am | \
xargs ${PERL} -pi -e "s;-lXm ;${MOTIFLIB} ;g"
@@ -53,4 +60,4 @@ post-install:
xargs ${PERL} -pi -e "s;/usr/lpp;${PREFIX};g"
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>