aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2018-03-17 23:58:01 +0800
committercmt <cmt@FreeBSD.org>2018-03-17 23:58:01 +0800
commitdd0bbb92b6b9efc2d9d216d22852540d5e95a1a8 (patch)
tree8e777856887722577afb8648e111335682ab9dda /graphics
parent81d64a89f4679926468884d06ce08565ef80282e (diff)
downloadfreebsd-ports-gnome-dd0bbb92b6b9efc2d9d216d22852540d5e95a1a8.tar.gz
freebsd-ports-gnome-dd0bbb92b6b9efc2d9d216d22852540d5e95a1a8.tar.zst
freebsd-ports-gnome-dd0bbb92b6b9efc2d9d216d22852540d5e95a1a8.zip
update shotwell to 0.28.0
while here, massage OPENMP_DESC for generic GCC
Diffstat (limited to 'graphics')
-rw-r--r--graphics/shotwell/Makefile9
-rw-r--r--graphics/shotwell/distinfo6
-rw-r--r--graphics/shotwell/files/patch-configure.ac4
-rw-r--r--graphics/shotwell/files/patch-src-camera-CameraTable.vala13
-rw-r--r--graphics/shotwell/files/patch-src___transformation.c11
5 files changed, 28 insertions, 15 deletions
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 90f040c36b63..2d7454a1f8a9 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= shotwell
-PORTVERSION= 0.26.4
-PORTREVISION= 1
+PORTVERSION= 0.28.0
CATEGORIES= graphics gnome
MASTER_SITES= GNOME/sources/shotwell/${PORTVERSION:R}
@@ -22,6 +21,7 @@ LIB_DEPENDS= libappstream-glib.so:devel/appstream-glib \
libgcr-ui-3.so:security/gcr \
libgdata.so:devel/libgdata \
libgee-0.8.so:devel/libgee \
+ libgstapp-1.0.so:multimedia/gstreamer1-plugins \
libgstreamer-1.0.so:multimedia/gstreamer1 \
liblcms2.so:graphics/lcms2 \
libjson-glib-1.0.so:devel/json-glib \
@@ -33,7 +33,8 @@ LIB_DEPENDS= libappstream-glib.so:devel/appstream-glib \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libunique-1.0.so:x11-toolkits/unique \
libraw.so:graphics/libraw \
- librest-0.7.so:devel/librest
+ librest-0.7.so:devel/librest \
+ libxml2.so:textproc/libxml2
USES= autoreconf gettext desktop-file-utils gmake libtool pkgconfig \
sqlite tar:xz
@@ -50,7 +51,7 @@ PORTSCOUT= limitw:1,even
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= OPENMP NLS
-OPENMP_DESC= libraw uses OpenMP (implies GCC 4.9+)
+OPENMP_DESC= libraw uses OpenMP (implies GCC)
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
diff --git a/graphics/shotwell/distinfo b/graphics/shotwell/distinfo
index 798c82fd1bd2..cefdf763cf14 100644
--- a/graphics/shotwell/distinfo
+++ b/graphics/shotwell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1510337319
-SHA256 (shotwell-0.26.4.tar.xz) = 70802d290419454e3194f6cf4a74db6c5a5ee2674f92809477083bcf58d32cd8
-SIZE (shotwell-0.26.4.tar.xz) = 5619280
+TIMESTAMP = 1521293908
+SHA256 (shotwell-0.28.0.tar.xz) = afce116d2f0fd2013aee0510038daa466b40b439ab18086236faa54fab3de9b4
+SIZE (shotwell-0.28.0.tar.xz) = 5584464
diff --git a/graphics/shotwell/files/patch-configure.ac b/graphics/shotwell/files/patch-configure.ac
index 69ee63ff16e8..6ef6f12a42ae 100644
--- a/graphics/shotwell/files/patch-configure.ac
+++ b/graphics/shotwell/files/patch-configure.ac
@@ -1,9 +1,9 @@
---- configure.ac.orig 2017-03-26 06:57:42 UTC
+--- configure.ac.orig 2018-03-17 13:41:22 UTC
+++ configure.ac
@@ -114,7 +114,6 @@ PKG_CHECK_MODULES(SHOTWELL, [
gstreamer-plugins-base-1.0 >= 1.0.0
gstreamer-pbutils-1.0 >= 1.0.0
- gtk+-3.0 >= 3.14.0
+ gtk+-3.0 >= 3.18.0
- gudev-1.0 >= 145
libexif >= 0.6.16
libgphoto2 >= 2.5.0
diff --git a/graphics/shotwell/files/patch-src-camera-CameraTable.vala b/graphics/shotwell/files/patch-src-camera-CameraTable.vala
index 1e8d73164927..3ec7686e9f2e 100644
--- a/graphics/shotwell/files/patch-src-camera-CameraTable.vala
+++ b/graphics/shotwell/files/patch-src-camera-CameraTable.vala
@@ -1,4 +1,4 @@
---- src/camera/CameraTable.vala.orig 2017-02-25 22:55:36 UTC
+--- src/camera/CameraTable.vala.orig 2018-03-10 06:42:15 UTC
+++ src/camera/CameraTable.vala
@@ -26,7 +26,6 @@ public class CameraTable {
@@ -83,7 +83,7 @@
private void update_camera_table() throws GPhotoError {
// need to do this because virtual ports come and go in the USB world (and probably others)
-@@ -326,22 +282,7 @@ public class CameraTable {
+@@ -326,23 +282,7 @@ public class CameraTable {
}
// Get display name for camera.
@@ -103,11 +103,12 @@
- display_name = device.get_property("ID_MODEL");
- }
- }
+-
+ // in absence of udev, we fall back to the GPhoto name
- if (null == display_name) {
- // Default to GPhoto detected name.
- display_name = name;
-@@ -381,14 +322,8 @@ public class CameraTable {
+ if (port.has_prefix("disk:")) {
+ try {
+ var mount = File.new_for_path (port.substring(5)).find_enclosing_mount();
+@@ -391,14 +331,8 @@ public class CameraTable {
camera_added(camera);
}
}
diff --git a/graphics/shotwell/files/patch-src___transformation.c b/graphics/shotwell/files/patch-src___transformation.c
new file mode 100644
index 000000000000..9e18c8094433
--- /dev/null
+++ b/graphics/shotwell/files/patch-src___transformation.c
@@ -0,0 +1,11 @@
+--- src/_transformation.c.orig 2018-03-17 15:06:02 UTC
++++ src/_transformation.c
+@@ -7,7 +7,7 @@
+
+ #include "shotwell-graphics-processor.h"
+
+-inline void _pixel_transformer_apply_transformations (PixelTransformer* self, RGBAnalyticPixel* p, RGBAnalyticPixel* result) {
++void _pixel_transformer_apply_transformations (PixelTransformer* self, RGBAnalyticPixel* p, RGBAnalyticPixel* result) {
+ PixelFormat current_format = PIXEL_FORMAT_RGB;
+ RGBAnalyticPixel p_rgb = {p->red, p->green, p->blue };
+ HSVAnalyticPixel p_hsv = {0.0f, 0.0f, 0.0f};