aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:37:44 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:37:44 +0800
commite4c18f2955f27cbf53bbe698b6182ffe3eb91f30 (patch)
treef9e659e32fcfa76d66c0b6fa01e9a87e7ca1c4a6 /graphics
parent95b6ba9e63e84046c152afeb7a530d2485f9dd3d (diff)
downloadfreebsd-ports-gnome-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.tar.gz
freebsd-ports-gnome-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.tar.zst
freebsd-ports-gnome-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/metapixel/Makefile7
-rw-r--r--graphics/metapixel/files/patch-Makefile14
2 files changed, 11 insertions, 10 deletions
diff --git a/graphics/metapixel/Makefile b/graphics/metapixel/Makefile
index f9c14df17e63..30c3f730853c 100644
--- a/graphics/metapixel/Makefile
+++ b/graphics/metapixel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= metapixel
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/
@@ -13,11 +14,13 @@ MAINTAINER= arved@FreeBSD.org
COMMENT= "Metapixel is a program for generating photomosaics"
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_REINPLACE= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
post-patch:
@${RM} ${WRKSRC}/getopt.h
diff --git a/graphics/metapixel/files/patch-Makefile b/graphics/metapixel/files/patch-Makefile
index 0fb1d77c5150..0da82060c998 100644
--- a/graphics/metapixel/files/patch-Makefile
+++ b/graphics/metapixel/files/patch-Makefile
@@ -1,22 +1,20 @@
---- Makefile.orig Fri Jan 21 23:32:17 2000
-+++ Makefile Tue Sep 24 03:40:26 2002
-@@ -1,18 +1,18 @@
+--- Makefile.orig Sat Jan 22 07:32:17 2000
++++ Makefile Sun Jul 6 19:40:11 2003
+@@ -1,5 +1,3 @@
-PREFIX = /usr/local
-INSTALL = install
BINDIR = $(PREFIX)/bin
- VERSION = 0.7
+@@ -7,12 +5,12 @@
#PROFILE = -pg
-+CFLAGS+= -I/usr/local/include
-+LDFLAGS+= -L/usr/local/lib -lgnugetopt
-LDOPTS = -L/usr/X11R6/lib $(PROFILE)
-CCOPTS = -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall -O9 $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
-CC = gcc
-+LDOPTS = ${LDFLAGS} -L/usr/X11R6/lib $(PROFILE)
-+CCOPTS = ${CFLAGS} -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
++LDOPTS = ${LDFLAGS} $(PROFILE)
++CCOPTS = ${CFLAGS} ${CPPFLAGS} -Wall $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
+#CC = gcc
#LIBFFM = -lffm