aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-24 20:30:45 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-24 20:30:45 +0800
commitf88247211808c3d44d218ac2ef993ed3976b4de5 (patch)
treee1e337817ef5a9bf011f45e76e5165f40906abeb /graphics
parentf3398bdd24a71fba2aa37b120d0bd2b6a9446964 (diff)
downloadfreebsd-ports-gnome-f88247211808c3d44d218ac2ef993ed3976b4de5.tar.gz
freebsd-ports-gnome-f88247211808c3d44d218ac2ef993ed3976b4de5.tar.zst
freebsd-ports-gnome-f88247211808c3d44d218ac2ef993ed3976b4de5.zip
- Pet stage-qa:
- Remove STAGEDIR prefix from .packlist - Strip shared library - Use MAKE_CMD - Bump PORTREVISION for package change
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Geo-GDAL/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/p5-Geo-GDAL/Makefile b/graphics/p5-Geo-GDAL/Makefile
index 9d0d40d94424..d31656a42b61 100644
--- a/graphics/p5-Geo-GDAL/Makefile
+++ b/graphics/p5-Geo-GDAL/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Geo-GDAL
PORTVERSION= 1.10.1
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://download.osgeo.org/gdal/ \
ftp://ftp.remotesensing.org/pub/gdal/ \
@@ -24,7 +25,12 @@ post-patch:
@${REINPLACE_CMD} -e 's| install| pure_install|' ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e 's|(const char \*)""|(char \*)""|' ${WRKSRC}/gdal_wrap.cpp ${WRKSRC}/ogr_wrap.cpp
+post-install:
+ ${SED} -i '' 's|^${STAGEDIR}||' ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/GDAL/Const/.packlist ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/*/.packlist
+ ${CHMOD} u+w ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/GDAL/Const/Const.so ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/*/*.so
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/GDAL/Const/Const.so ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Geo/*/*.so
+
regression-test test: build
- cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} test || ${TRUE}
+ -cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
.include <bsd.port.mk>