aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorimura <imura@FreeBSD.org>2000-10-24 00:09:07 +0800
committerimura <imura@FreeBSD.org>2000-10-24 00:09:07 +0800
commitfbc2408f48a54708c5f1b7b70cc82d537d434c27 (patch)
treef465c2e519efb82d03f16717a9961e6c45782c07 /graphics
parent4d7670ea88575d979183487e6d38a45dbb4faf75 (diff)
downloadfreebsd-ports-gnome-fbc2408f48a54708c5f1b7b70cc82d537d434c27.tar.gz
freebsd-ports-gnome-fbc2408f48a54708c5f1b7b70cc82d537d434c27.tar.zst
freebsd-ports-gnome-fbc2408f48a54708c5f1b7b70cc82d537d434c27.zip
Make it PREFIX-safe.
Submitted by: will
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kdegraphics11/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/graphics/kdegraphics11/Makefile b/graphics/kdegraphics11/Makefile
index 4df609862a09..0be14747f720 100644
--- a/graphics/kdegraphics11/Makefile
+++ b/graphics/kdegraphics11/Makefile
@@ -20,10 +20,20 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
USE_BZIP2= yes
USE_QT= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= "--prefix=$(PREFIX)"
+CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
+ "--with-qt-includes=${QTDIR}/include/X11/qt" \
+ "--with-extra-includes=${LOCALBASE}/include" \
+ "--with-extra-libs=${LOCALBASE}/lib"
CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
- INSTALL_SCRIPT="install -c -m 555"
+ INSTALL_SCRIPT="install -c -m 555" \
+ QTDIR=${QTDIR}
CFLAGS+= "-I${PREFIX}/include"
USE_GMAKE= yes
+.if defined(PREFIX)
+QTDIR?= ${PREFIX}
+.else
+QTDIR?= ${X11BASE}
+.endif
+
.include <bsd.port.mk>