aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-09-24 01:10:17 +0800
committeroliver <oliver@FreeBSD.org>2007-09-24 01:10:17 +0800
commitfd81ba8f45d502c036ceb8abd257f12b9cc71650 (patch)
treecdeaa781fb7300877060d3ef870cd3d2de8f4368 /graphics
parent87ad2e05052c9f324f5a85456c41a0da98addf74 (diff)
downloadfreebsd-ports-gnome-fd81ba8f45d502c036ceb8abd257f12b9cc71650.tar.gz
freebsd-ports-gnome-fd81ba8f45d502c036ceb8abd257f12b9cc71650.tar.zst
freebsd-ports-gnome-fd81ba8f45d502c036ceb8abd257f12b9cc71650.zip
fix the removing of the "Samples" SUBDIR from the ports Makefile by using
a propper regexp. PR: ports/116499 Submitted by: amdmi3@amdmi3.ru
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cegui/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 6755465650b8..64d2e29fe251 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -36,7 +36,7 @@ post-patch:
s|-lpthread|${PTHREAD_LIBS}|g; \
s|DevIL_CFLAGS=.*|DevIL_CFLAGS="-DUSE_DEVIL_LIBRARY -I${LOCALBASE}/include"|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's| Samples$$||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/SUBDIRS/ s| Samples||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|__linux__)|& \|\| defined(__FreeBSD__)|g' \
${WRKSRC}/include/CEGUIDynamicModule.h \
${WRKSRC}/src/CEGUIDynamicModule.cpp