aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-03-23 04:26:27 +0800
committerrm <rm@FreeBSD.org>2016-03-23 04:26:27 +0800
commitf1bce709a314c52a00443856064d8d811f33afcb (patch)
treebaf8e619c411e01068695359e4b32aa2ed5e0d7e /graphics
parent6765e91b48d306df9988480f7a00e3786c94793f (diff)
downloadfreebsd-ports-gnome-f1bce709a314c52a00443856064d8d811f33afcb.tar.gz
freebsd-ports-gnome-f1bce709a314c52a00443856064d8d811f33afcb.tar.zst
freebsd-ports-gnome-f1bce709a314c52a00443856064d8d811f33afcb.zip
graphics/gimp-gmic-plugin: simplify port a bit
- utilize USES=localbase - simplify BASH options dependency - further convert to options helpers and drop including of bsd.port.options.mk
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-gmic-plugin/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 9e4fc99e157f..dcdf0ec8e864 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -21,11 +21,11 @@ LIB_DEPENDS= libGraphicsMagick++.so:${PORTSDIR}/graphics/GraphicsMagick \
OPTIONS_DEFINE= BASH
OPTIONS_SUB= yes
-BASH_RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+BASH_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-USES= gmake pkgconfig
+USES= gmake localbase pkgconfig
USE_GCC= yes
USE_GNOME= gtk20
USE_XORG= x11 xext xrandr
@@ -33,8 +33,6 @@ USE_XORG= x11 xext xrandr
PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-O*:N-pipe}
CXXFLAGS:= ${CXXFLAGS:N-O*:N-pipe}
@@ -46,8 +44,6 @@ PLIST_FILES= bin/gmic \
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
PORTEXAMPLES= gmic_in_script.scm gmic_use_lib.cpp
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's#/usr/X11R6#${PREFIX}#g' \
${WRKSRC}/Makefile
@@ -59,10 +55,9 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/../man/gmic.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
-.if ${PORT_OPTIONS:MBASH}
+do-install-BASH-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_SCRIPT} ${WRKSRC}/../resources/gmic_bashcompletion.sh \
${STAGEDIR}${PREFIX}/etc/bash_completion.d
-.endif
.include <bsd.port.mk>