aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormita <mita@FreeBSD.org>2002-07-26 07:55:17 +0800
committermita <mita@FreeBSD.org>2002-07-26 07:55:17 +0800
commit017d82593988e57c366c99958aadc892c4465396 (patch)
tree5242219d2182e1826922a432f0491449682bce30 /graphics
parent73042b39279eac2fcb710b043e6ce669bad3d600 (diff)
downloadfreebsd-ports-gnome-017d82593988e57c366c99958aadc892c4465396.tar.gz
freebsd-ports-gnome-017d82593988e57c366c99958aadc892c4465396.tar.zst
freebsd-ports-gnome-017d82593988e57c366c99958aadc892c4465396.zip
Yet another PS -> EPSI converter that is compatible with Tgif.
PR: ports/40906
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pstoepsi/Makefile40
-rw-r--r--graphics/pstoepsi/distinfo2
-rw-r--r--graphics/pstoepsi/pkg-comment1
-rw-r--r--graphics/pstoepsi/pkg-descr11
-rw-r--r--graphics/pstoepsi/pkg-plist3
6 files changed, 58 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4d6b5f741c1f..6dc33e9394c6 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -283,6 +283,7 @@
SUBDIR += ppmcaption
SUBDIR += proj
SUBDIR += pstoedit
+ SUBDIR += pstoepsi
SUBDIR += pvmpov
SUBDIR += py-exif
SUBDIR += py-gd
diff --git a/graphics/pstoepsi/Makefile b/graphics/pstoepsi/Makefile
new file mode 100644
index 000000000000..ab14e2576cf3
--- /dev/null
+++ b/graphics/pstoepsi/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pstoepsi
+# Date created: 21 Jul 2002
+# Whom: Mita Yoshio <mita@jp.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pstoepsi
+PORTVERSION= 20020711
+CATEGORIES= graphics
+MASTER_SITES= ftp://bourbon.usc.edu/pub/tgif/tools/pstoepsi/
+DISTFILES= pstoepsi README.this-site
+DIST_SUBDIR= pstoepsi
+EXTRACT_ONLY= #empty
+
+MAINTAINER= mita@FreeBSD.org
+
+RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm \
+ gs:${PORTSDIR}/print/ghostscript-gnu
+
+NO_WRKSUBDIR= yes
+
+.SILENT:
+
+pre-patch:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/pstoepsi ${WRKDIR}/pstoepsi.prefix
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/README.this-site ${WRKDIR}
+
+do-build:
+ ${SED} -e "s+%%PREFIX%%+${PREFIX}+g" ${WRKDIR}/pstoepsi.prefix > \
+ ${WRKDIR}/pstoepsi
+ ${GZIP_CMD} ${WRKDIR}/README.this-site
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/pstoepsi ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/pstoepsi
+ ${INSTALL_DATA} ${WRKDIR}/README.this-site.gz \
+ ${PREFIX}/share/doc/pstoepsi
+
+.include <bsd.port.mk>
diff --git a/graphics/pstoepsi/distinfo b/graphics/pstoepsi/distinfo
new file mode 100644
index 000000000000..1d3c46418da0
--- /dev/null
+++ b/graphics/pstoepsi/distinfo
@@ -0,0 +1,2 @@
+MD5 (pstoepsi/pstoepsi) = dad3b391a9eeef0ba79c90dcd71d42a8
+MD5 (pstoepsi/README.this-site) = 0050cf77d3e8361fc78edd93917712ce
diff --git a/graphics/pstoepsi/pkg-comment b/graphics/pstoepsi/pkg-comment
new file mode 100644
index 000000000000..8ca6d5d53270
--- /dev/null
+++ b/graphics/pstoepsi/pkg-comment
@@ -0,0 +1 @@
+Wiliam Chia-Wei Cheng's yet another PS to EPSI converter
diff --git a/graphics/pstoepsi/pkg-descr b/graphics/pstoepsi/pkg-descr
new file mode 100644
index 000000000000..8c52a47b6923
--- /dev/null
+++ b/graphics/pstoepsi/pkg-descr
@@ -0,0 +1,11 @@
+pstoepsi convertes EPS (and some PS) file to EPS file with Image preview.
+This EPSI file is very useful to import to Tgif (with 'Ctrl-(' key).
+
+Ghostscript has similar script (ps2epsi) but since version 7.05 it no more
+creates EPSI files which are compatible with tgif.
+
+Using is very simple:
+
+pstoepsi input_file_name output_file_name.epsi
+
+You will find that output_file_name.epsi in the same directory.
diff --git a/graphics/pstoepsi/pkg-plist b/graphics/pstoepsi/pkg-plist
new file mode 100644
index 000000000000..88a6d7cc2edb
--- /dev/null
+++ b/graphics/pstoepsi/pkg-plist
@@ -0,0 +1,3 @@
+bin/pstoepsi
+share/doc/pstoepsi/README.this-site.gz
+@dirrm share/doc/pstoepsi