aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-12-22 19:42:11 +0800
committertijl <tijl@FreeBSD.org>2013-12-22 19:42:11 +0800
commit096d3a3a4ca0836aaf323c1a6565b4807d2510f1 (patch)
treef06e4e616907aae06b1504b8d862b37c45e152b6 /graphics
parentb4f915b2593c950ecc29f8c0610feae9be9b1528 (diff)
downloadfreebsd-ports-gnome-096d3a3a4ca0836aaf323c1a6565b4807d2510f1.tar.gz
freebsd-ports-gnome-096d3a3a4ca0836aaf323c1a6565b4807d2510f1.tar.zst
freebsd-ports-gnome-096d3a3a4ca0836aaf323c1a6565b4807d2510f1.zip
- Add DOCS option.
- USES=fortran and fix build with Clang (-Wno-return-type). - Staging.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gplot/Makefile32
-rw-r--r--graphics/gplot/pkg-plist5
2 files changed, 15 insertions, 22 deletions
diff --git a/graphics/gplot/Makefile b/graphics/gplot/Makefile
index e1e97f94a95d..ae50cf32e078 100644
--- a/graphics/gplot/Makefile
+++ b/graphics/gplot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gplot
PORTVERSION= 4.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.psc.edu/pub/gplot/
DISTNAME= ${PORTNAME}
@@ -12,26 +12,22 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphic utilities for the processing of CGM metafiles
+OPTIONS_DEFINE= DOCS
+
+CFLAGS+= -Wno-return-type
NO_WRKSUBDIR= yes
ALL_TARGET= drawcgm gtex gplot
-MAN1= gplot.1
-DOCS= gplot.hlp gplot.txt gtex.doc
-USE_FORTRAN= yes
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PORTDOCS= gplot.hlp gplot.txt gtex.doc
+USES= fortran
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gplot ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/gtex ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/drawcgm/drawcgm.a ${PREFIX}/lib/libcgm.a
- ${INSTALL_MAN} ${WRKSRC}/gplot.man ${PREFIX}/man/man1/gplot.1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/Gplot
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/share/doc/Gplot
- ${GZIP_CMD} ${PREFIX}/share/doc/Gplot/$f
+ ${INSTALL_PROGRAM} ${WRKSRC}/gplot ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/gtex ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/drawcgm/drawcgm.a ${STAGEDIR}${PREFIX}/lib/libcgm.a
+ ${INSTALL_MAN} ${WRKSRC}/gplot.man ${STAGEDIR}${PREFIX}/man/man1/gplot.1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gplot/pkg-plist b/graphics/gplot/pkg-plist
index b533137a660d..871e999e4b79 100644
--- a/graphics/gplot/pkg-plist
+++ b/graphics/gplot/pkg-plist
@@ -1,7 +1,4 @@
bin/gplot
bin/gtex
lib/libcgm.a
-%%PORTDOCS%%share/doc/Gplot/gplot.hlp.gz
-%%PORTDOCS%%share/doc/Gplot/gplot.txt.gz
-%%PORTDOCS%%share/doc/Gplot/gtex.doc.gz
-%%PORTDOCS%%@dirrm share/doc/Gplot
+man/man1/gplot.1.gz