aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-29 22:43:07 +0800
committerjohans <johans@FreeBSD.org>2013-12-29 22:43:07 +0800
commit143f60a5be31e070ea3668be973421eb906575b4 (patch)
tree43d23c4ebddd5a1aa71e0d2eb3a8ae776a176f28 /graphics
parent99fb9657672d4ce480b55af2e9df937041442b2b (diff)
downloadfreebsd-ports-gnome-143f60a5be31e070ea3668be973421eb906575b4.tar.gz
freebsd-ports-gnome-143f60a5be31e070ea3668be973421eb906575b4.tar.zst
freebsd-ports-gnome-143f60a5be31e070ea3668be973421eb906575b4.zip
Enable stage support
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dmtx-utils/Makefile8
-rw-r--r--graphics/dmtx-utils/pkg-descr2
-rw-r--r--graphics/libdmtx/Makefile7
-rw-r--r--graphics/libdmtx/pkg-descr2
-rw-r--r--graphics/libdmtx/pkg-plist1
5 files changed, 9 insertions, 11 deletions
diff --git a/graphics/dmtx-utils/Makefile b/graphics/dmtx-utils/Makefile
index d19f67d8d16f..7f6c496ee7c9 100644
--- a/graphics/dmtx-utils/Makefile
+++ b/graphics/dmtx-utils/Makefile
@@ -11,14 +11,14 @@ MASTER_SITE_SUBDIR=libdmtx/libdmtx/${PORTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= Software for reading and writing Data Matrix barcodes
-LIB_DEPENDS= dmtx.0:${PORTSDIR}/graphics/libdmtx
+LIB_DEPENDS= libdmtx.so:${PORTSDIR}/graphics/libdmtx
USE_BZIP2= yes
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-MAN1= dmtxread.1 dmtxwrite.1 dmtxquery.1
-PLIST_FILES= bin/dmtxread bin/dmtxwrite bin/dmtxquery
+PLIST_FILES= bin/dmtxread bin/dmtxwrite bin/dmtxquery \
+ man/man1/dmtxread.1.gz man/man1/dmtxwrite.1.gz \
+ man/man1/dmtxquery.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/dmtx-utils/pkg-descr b/graphics/dmtx-utils/pkg-descr
index b30ca78e1fd2..4ed21b516219 100644
--- a/graphics/dmtx-utils/pkg-descr
+++ b/graphics/dmtx-utils/pkg-descr
@@ -12,4 +12,4 @@ pattern of data with built-in error correction. The Data Matrix
symbology (sometimes casually referred to as "DataMatrix") was invented
and released into the public domain by RVSI Acuity CiMatrix.
-WWW: http://www.libdmtx.org/
+WWW: http://www.libdmtx.org/
diff --git a/graphics/libdmtx/Makefile b/graphics/libdmtx/Makefile
index 39619b3080b0..fe84601133f6 100644
--- a/graphics/libdmtx/Makefile
+++ b/graphics/libdmtx/Makefile
@@ -10,17 +10,14 @@ MASTER_SITES= SF
MAINTAINER= johans@FreeBSD.org
COMMENT= Library for reading and writing Data Matrix barcodes
-LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick
-
-MAN3= libdmtx.3
+LIB_DEPENDS= libMagickWand.so:${PORTSDIR}/graphics/ImageMagick
USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e '/^pkgconfigdir /s:(libdir):{prefix}/libdata:' \
+ @${REINPLACE_CMD} -e '/^pkgconfigdir /s:(libdir):{prefix}/libdata:' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/libdmtx/pkg-descr b/graphics/libdmtx/pkg-descr
index f70fc206753c..261d66549590 100644
--- a/graphics/libdmtx/pkg-descr
+++ b/graphics/libdmtx/pkg-descr
@@ -10,4 +10,4 @@ pattern of data with built-in error correction. The Data Matrix
symbology (sometimes casually referred to as "DataMatrix") was invented
and released into the public domain by RVSI Acuity CiMatrix.
-WWW: http://www.libdmtx.org/
+WWW: http://www.libdmtx.org/
diff --git a/graphics/libdmtx/pkg-plist b/graphics/libdmtx/pkg-plist
index 90090d1fc87a..d5c4f9a9cc38 100644
--- a/graphics/libdmtx/pkg-plist
+++ b/graphics/libdmtx/pkg-plist
@@ -4,3 +4,4 @@ lib/libdmtx.so.0
lib/libdmtx.la
lib/libdmtx.a
libdata/pkgconfig/libdmtx.pc
+man/man3/libdmtx.3.gz