aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-29 02:40:01 +0800
committeryuri <yuri@FreeBSD.org>2018-07-29 02:40:01 +0800
commit18fc2ad93589ef0a3820ce8c7109a5808a066a16 (patch)
tree860511c6da7119e61a04f40dc946be996f864f09 /graphics
parentdfc0dcf6f82d3e95c57eb4360e2bc0593819c71a (diff)
downloadfreebsd-ports-gnome-18fc2ad93589ef0a3820ce8c7109a5808a066a16.tar.gz
freebsd-ports-gnome-18fc2ad93589ef0a3820ce8c7109a5808a066a16.tar.zst
freebsd-ports-gnome-18fc2ad93589ef0a3820ce8c7109a5808a066a16.zip
New port: graphics/py-pyinsane2: Python library to access and use image scanners
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pyinsane2/Makefile22
-rw-r--r--graphics/py-pyinsane2/distinfo3
-rw-r--r--graphics/py-pyinsane2/pkg-descr13
4 files changed, 39 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 678c15a14edd..6eb06ae2f41b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -937,6 +937,7 @@
SUBDIR += py-pyglet
SUBDIR += py-pygooglechart
SUBDIR += py-pygraphviz
+ SUBDIR += py-pyinsane2
SUBDIR += py-pyocr
SUBDIR += py-pypillowfight
SUBDIR += py-pyproj
diff --git a/graphics/py-pyinsane2/Makefile b/graphics/py-pyinsane2/Makefile
new file mode 100644
index 000000000000..f7b56a9ca7c5
--- /dev/null
+++ b/graphics/py-pyinsane2/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= pyinsane2
+DISTVERSION= 2.0.13
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python library to access and use image scanners
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+
+USES= gmake python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyinsane2/distinfo b/graphics/py-pyinsane2/distinfo
new file mode 100644
index 000000000000..77f49fde3e19
--- /dev/null
+++ b/graphics/py-pyinsane2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532801560
+SHA256 (pyinsane2-2.0.13.tar.gz) = 0d519531d552e4512776225eb400a6a4a9bfc83a08918ec7fea19cb2fa7ec4ee
+SIZE (pyinsane2-2.0.13.tar.gz) = 57172
diff --git a/graphics/py-pyinsane2/pkg-descr b/graphics/py-pyinsane2/pkg-descr
new file mode 100644
index 000000000000..bbe037560767
--- /dev/null
+++ b/graphics/py-pyinsane2/pkg-descr
@@ -0,0 +1,13 @@
+Python library to access and use image scanners.
+
+Support for:
+* Sane (Scanners on GNU/Linux, *BSD, MacOSX, etc)
+* WIA 2 (Windows Image Acquisition ; Scanners on Microsoft Windows >= Vista)
+
+It supports:
+* Flatbed
+* Automatic Document Feeder
+* While scanning, can provide chunks of the image for on-the-fly preview
+ (see Paperwork for instance)
+
+WWW: https://gitlab.gnome.org/World/OpenPaperwork/pyinsane/