aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-24 20:40:58 +0800
committerbapt <bapt@FreeBSD.org>2014-03-24 20:40:58 +0800
commit3a6ca7f6af34010b20dadca7318d584e97064790 (patch)
tree1e84a5977d8f5aa9e6089bcfd1d638f71459519b /graphics
parent841c4adb44d294f1a3d0345958a2d034564319f1 (diff)
downloadfreebsd-ports-gnome-3a6ca7f6af34010b20dadca7318d584e97064790.tar.gz
freebsd-ports-gnome-3a6ca7f6af34010b20dadca7318d584e97064790.tar.zst
freebsd-ports-gnome-3a6ca7f6af34010b20dadca7318d584e97064790.zip
Convert to new options framework
Remove wxgtk option which is broken with all support version of wxgtk
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zphoto/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index c9ce81169ea2..aa762b1daf6c 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -11,11 +11,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= umeno@rr.iij4u.or.jp
COMMENT= Zooming photo album generator
-LIB_DEPENDS= ming.5:${PORTSDIR}/graphics/ming \
- popt.0:${PORTSDIR}/devel/popt
-.if !defined (WITHOUT_ZIP)
-RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
-.endif
+OPTIONS_DEFINE= ZIP
+OPTIONS_DEFAULT= ZIP
+ZIP_DESC= Enable zip support
+
+LIB_DEPENDS= libming.so:${PORTSDIR}/graphics/ming \
+ libpopt.so:${PORTSDIR}/devel/popt
+
+ZIP_RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+ZIP_CONFIGURE_OFF= --disable-zip
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-avifile
@@ -23,18 +27,8 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
USE_EFL= imlib2
-.if defined (WITH_WXGTK2)
-USE_WX= 2.4
-WX_CONF_ARGS= absolute
PLIST_FILES+= bin/wxzphoto
-.else
-CONFIGURE_ARGS+= --disable-wx
-.endif
-.if defined (WITHOUT_ZIP)
-CONFIGURE_ARGS+= --disable-zip
-.endif
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
NO_STAGE= yes