aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-08-06 05:25:43 +0800
committerpat <pat@FreeBSD.org>2002-08-06 05:25:43 +0800
commit599c9ccff9a349a52c569c5c1907c8af9c87d2fc (patch)
tree5ffa5d3a2b990e4649d53605efdf565fa9c88df2 /graphics
parent874023af06fec2175a230ccb105ef65d410147b7 (diff)
downloadfreebsd-ports-gnome-599c9ccff9a349a52c569c5c1907c8af9c87d2fc.tar.gz
freebsd-ports-gnome-599c9ccff9a349a52c569c5c1907c8af9c87d2fc.tar.zst
freebsd-ports-gnome-599c9ccff9a349a52c569c5c1907c8af9c87d2fc.zip
- PERL -> REINPLACE_CMD
- Fix xmms dependency not registering PR: ports/41098 Submitted by: Adam Weinberger <adam@vectors.cx> Approved by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xmms-infinity/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/xmms-infinity/Makefile b/graphics/xmms-infinity/Makefile
index 1902f6386702..1ef96bda7b0e 100644
--- a/graphics/xmms-infinity/Makefile
+++ b/graphics/xmms-infinity/Makefile
@@ -13,8 +13,8 @@ DISTNAME= infinity-${PORTVERSION}
MAINTAINER= dyeske@yahoo.com
-LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
-LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms \
+ SDL-1.1.4:${PORTSDIR}/devel/sdl12
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -22,12 +22,13 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GTK= yes
USE_X_PREFIX= yes
pre-patch:
- @${PERL} -pi -e 's|SDL/|SDL11/|g;' \
- ${WRKSRC}/*.[ch] ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' ${WRKSRC}/*.[ch] \
+ ${WRKSRC}/configure
.include <bsd.port.mk>