aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-01 08:39:26 +0800
committerpav <pav@FreeBSD.org>2004-04-01 08:39:26 +0800
commit866a71f355f9c0b6d6bd903dc5d919c5a40e578f (patch)
treeba8e9511ee4c02c6ccdbf4775454dda4efbf8055 /graphics
parent795637e4f2090f803d8f238233bc0b8542f7f5c4 (diff)
downloadfreebsd-ports-gnome-866a71f355f9c0b6d6bd903dc5d919c5a40e578f.tar.gz
freebsd-ports-gnome-866a71f355f9c0b6d6bd903dc5d919c5a40e578f.tar.zst
freebsd-ports-gnome-866a71f355f9c0b6d6bd903dc5d919c5a40e578f.zip
- Netcdf and Hdf conflicts, so let user choose which one to build against.
PR: ports/64960 Submitted by: Kay Lehmann <kay_lehmann@web.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opendx/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 960a80e3f742..7d479ebb66fa 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -17,11 +17,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= IBM's Open Visualization Data Explorer
LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
- df.1:${PORTSDIR}/science/hdf \
- netcdf.1:${PORTSDIR}/math/netcdf \
tiff.4:${PORTSDIR}/graphics/tiff
-BROKEN= "Inconsistent dependencies (netcdf and hdf)"
+OPTIONS= HDF "Build hdf-support (only hdf OR netcdf is supported)" on \
+ NETCDF "Build netcdf-support" off
USE_REINPLACE= yes
USE_BISON= yes
@@ -29,7 +28,7 @@ USE_MESA= yes
USE_MOTIF= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-javadx
+CONFIGURE_ARGS= --without-javadx
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV= ARCH="freebsd" \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
@@ -38,6 +37,16 @@ USE_GMAKE= yes
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_HDF)
+LIB_DEPENDS+= df.1:${PORTSDIR}/science/hdf
+.endif
+
+.if defined(WITH_NETCDF)
+LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
.for dir in doc help html man
@@ -45,4 +54,4 @@ post-patch:
${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>