aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-22 16:03:57 +0800
committermiwi <miwi@FreeBSD.org>2014-05-22 16:03:57 +0800
commita40535b624ec1df657c0eb358d05e5e1637a1943 (patch)
tree3472b6a61539ce62ba8343e27ee6f6a70184f188 /graphics
parent52cb55f6bc1378102ba00ac249a95edbdaeb60a7 (diff)
downloadfreebsd-ports-gnome-a40535b624ec1df657c0eb358d05e5e1637a1943.tar.gz
freebsd-ports-gnome-a40535b624ec1df657c0eb358d05e5e1637a1943.tar.zst
freebsd-ports-gnome-a40535b624ec1df657c0eb358d05e5e1637a1943.zip
This package provides encoder/decoder implementation for DEC SIXEL graphics,
and some converter programs. SIXEL is one of image formats for terminal imaging introduced by DEC VT series. Its data scheme is represented as a terminal-friendly escape sequence. So if you want to view a SIXEL image file, all you have to do is "cat" it to your terminal. WWW: https://github.com/saitoha/libsixel PR: ports/188937 Submitted by: sue@iwmt.org
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libsixel/Makefile27
-rw-r--r--graphics/libsixel/distinfo2
-rw-r--r--graphics/libsixel/pkg-descr8
-rw-r--r--graphics/libsixel/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 49beed600256..3ea69baff95b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -535,6 +535,7 @@
SUBDIR += libraw
SUBDIR += libreatlas
SUBDIR += librsvg2
+ SUBDIR += libsixel
SUBDIR += libspiro
SUBDIR += libsvg
SUBDIR += libsvg-cairo
diff --git a/graphics/libsixel/Makefile b/graphics/libsixel/Makefile
new file mode 100644
index 000000000000..5ed231607fc2
--- /dev/null
+++ b/graphics/libsixel/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libsixel
+PORTVERSION= 20140422
+CATEGORIES= graphics
+
+MAINTAINER= sue@iwmt.org
+COMMENT= A encoder/decoder library for DEC SIXEL graphics
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= saitoha
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 8bd21f7
+
+GNU_CONFIGURE= yes
+
+PORTDOCS= README.md
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsixel.so.0
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/libsixel/distinfo b/graphics/libsixel/distinfo
new file mode 100644
index 000000000000..6b6d76a47113
--- /dev/null
+++ b/graphics/libsixel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libsixel-20140422.tar.gz) = 6910e7a8a5310ddc60909b9fce8e67a3c5017f1b37b56b00cb179c0baddc8d6c
+SIZE (libsixel-20140422.tar.gz) = 466077
diff --git a/graphics/libsixel/pkg-descr b/graphics/libsixel/pkg-descr
new file mode 100644
index 000000000000..0921fcea5555
--- /dev/null
+++ b/graphics/libsixel/pkg-descr
@@ -0,0 +1,8 @@
+This package provides encoder/decoder implementation for DEC SIXEL graphics,
+and some converter programs.
+SIXEL is one of image formats for terminal imaging introduced by DEC VT series.
+Its data scheme is represented as a terminal-friendly escape sequence.
+So if you want to view a SIXEL image file, all you have to do is "cat" it to
+your terminal.
+
+WWW: https://github.com/saitoha/libsixel
diff --git a/graphics/libsixel/pkg-plist b/graphics/libsixel/pkg-plist
new file mode 100644
index 000000000000..f4eccac98f60
--- /dev/null
+++ b/graphics/libsixel/pkg-plist
@@ -0,0 +1,7 @@
+include/sixel.h
+lib/libsixel.la
+lib/libsixel.so.0
+lib/libsixel.so
+lib/libsixel.a
+bin/img2sixel
+bin/sixel2png