aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-23 17:22:47 +0800
committermiwi <miwi@FreeBSD.org>2009-04-23 17:22:47 +0800
commitc82eb93939df6cbe01e27a602e5d32013308f207 (patch)
tree9e6a59e879fb9537aa47d278fc5130172e9010d9 /graphics
parente0406b59081d32f9c06dcd885317de251495b73c (diff)
downloadfreebsd-ports-gnome-c82eb93939df6cbe01e27a602e5d32013308f207.tar.gz
freebsd-ports-gnome-c82eb93939df6cbe01e27a602e5d32013308f207.tar.zst
freebsd-ports-gnome-c82eb93939df6cbe01e27a602e5d32013308f207.zip
Deegree's WPS is able to process Feature Collections based on arbitrary
processes. OGC's WPS (Schut & Whiteside 2005) specification describes WPS as follows: "WPS defines a standardized interface that facilitates the publishing of geospatial processes, and the discovery of and binding to those processes by clients. "Processes" include any algorithm, calculation or model that operates on spatially referenced data. "Publishing" means making available machine-readable binding information as well as human-readable metadata that allows service discovery and use." WWW: http://www.deegree.org/ PR: ports/133810 Submitted by: wenheping at gmail.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/deegree-wps/Makefile46
-rw-r--r--graphics/deegree-wps/distinfo3
-rw-r--r--graphics/deegree-wps/pkg-descr11
-rw-r--r--graphics/deegree-wps/pkg-message10
5 files changed, 71 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7656cea63d53..9d5f6f12a92c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -95,6 +95,7 @@
SUBDIR += deegree-wcs
SUBDIR += deegree-wfs
SUBDIR += deegree-wms
+ SUBDIR += deegree-wps
SUBDIR += demeter
SUBDIR += devil
SUBDIR += dia
diff --git a/graphics/deegree-wps/Makefile b/graphics/deegree-wps/Makefile
new file mode 100644
index 000000000000..7b95f7fc2554
--- /dev/null
+++ b/graphics/deegree-wps/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-wps
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= wps
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Deegree Web Processing Service(WPS)
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-wps
+PLIST_FILES= ${TOMCATVER}/webapps/deegree-wps.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 deegree-wps.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_WPS.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_wps_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/deegree-wps/distinfo b/graphics/deegree-wps/distinfo
new file mode 100644
index 000000000000..1469e13b21e5
--- /dev/null
+++ b/graphics/deegree-wps/distinfo
@@ -0,0 +1,3 @@
+MD5 (deegree-wps_v2_2.zip) = fc741793889206afbdfcd0bb236cd654
+SHA256 (deegree-wps_v2_2.zip) = 835824925db50e7617683c84d08d1678b923731c116e69fa574443a8d299dbaf
+SIZE (deegree-wps_v2_2.zip) = 8132883
diff --git a/graphics/deegree-wps/pkg-descr b/graphics/deegree-wps/pkg-descr
new file mode 100644
index 000000000000..03a93f423a10
--- /dev/null
+++ b/graphics/deegree-wps/pkg-descr
@@ -0,0 +1,11 @@
+Deegree's WPS is able to process Feature Collections based on arbitrary
+processes. OGC's WPS (Schut & Whiteside 2005) specification describes
+WPS as follows: "WPS defines a standardized interface that facilitates
+the publishing of geospatial processes, and the discovery of and binding
+to those processes by clients. "Processes" include any algorithm,
+calculation or model that operates on spatially referenced data.
+"Publishing" means making available machine-readable binding
+information as well as human-readable metadata that allows service
+discovery and use."
+
+WWW: http://www.deegree.org/
diff --git a/graphics/deegree-wps/pkg-message b/graphics/deegree-wps/pkg-message
new file mode 100644
index 000000000000..13df82f03621
--- /dev/null
+++ b/graphics/deegree-wps/pkg-message
@@ -0,0 +1,10 @@
+==========================================================================
+To start DeeGree correctly, please set the variable JAVA_OPTS with:
+
+setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
+
+Now you should start your Tomcat server and browse with:
+ http://your-server:8180/deegree-wcs
+
+Enjoy it !
+==========================================================================