aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-06-01 05:25:33 +0800
committermarcus <marcus@FreeBSD.org>2010-06-01 05:25:33 +0800
commitfd1daa527264ad979437cf0a5bff5dcd1774518d (patch)
treeba893c900a991fb57f5610cd17cad1a9e1dc358c /graphics
parent6f2a6429f6bd15f0cfd1e276fb1338863a7d6db5 (diff)
downloadfreebsd-ports-gnome-fd1daa527264ad979437cf0a5bff5dcd1774518d.tar.gz
freebsd-ports-gnome-fd1daa527264ad979437cf0a5bff5dcd1774518d.tar.zst
freebsd-ports-gnome-fd1daa527264ad979437cf0a5bff5dcd1774518d.zip
Make gnome-keyring and optional dependency when building without Nautilus.
Also, remove the libglade2 dependency which is no longer needed. PR: 147246 Submitted by: Pavel Gubin <pg@2lazy.ru>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evince/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index b497b6fa06a9..35da539cf06a 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -42,6 +42,7 @@ MAN1= evince.1
OPTIONS= DVI "Enable DVI viewer support" off \
T1LIB "Enable T1LIB for TYPE1 fonts to DVI (Enables DVI)" off \
NAUTILUS "Enable Nautilus plugin" on \
+ KEYRING "Enable Gnome-Keyring without Nautilus" on \
DBUS "Enable D-BUS support" on \
COMICS "Enable comic book archives support" on \
IMPRESS "Enable Impress presentations support" off \
@@ -76,8 +77,11 @@ PLIST_SUB+= NAUTILUS=""
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
RUN_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
+.if !defined(WITHOUT_KEYRING)
LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
-USE_GNOME+= libglade2
+.else
+CONFIGURE_ARGS+= --without-keyring
+.endif
CONFIGURE_ARGS+= --disable-nautilus
PLIST_SUB+= NAUTILUS="@comment "
.endif