aboutsummaryrefslogtreecommitdiffstats
path: root/irc/anope/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-12-29 21:45:41 +0800
committermat <mat@FreeBSD.org>2004-12-29 21:45:41 +0800
commit0a2ba62c3e6bcde3e1f9fb64b3c82525f731bbf0 (patch)
tree128e51eabd8b13e8df4a4f108c451e04c73f0c48 /irc/anope/Makefile
parent31e5fc754677a4be38d5aa6e40bcf76b4e49a276 (diff)
downloadfreebsd-ports-gnome-0a2ba62c3e6bcde3e1f9fb64b3c82525f731bbf0.tar.gz
freebsd-ports-gnome-0a2ba62c3e6bcde3e1f9fb64b3c82525f731bbf0.tar.zst
freebsd-ports-gnome-0a2ba62c3e6bcde3e1f9fb64b3c82525f731bbf0.zip
Make it really use threads when asked to [1]
While I'm here, make it respect CFLAGS PR: [1] based on 75349 Submitted by: [1] Axel Gonzalez <loox@e-shell.net>
Diffstat (limited to 'irc/anope/Makefile')
-rw-r--r--irc/anope/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index a918a337c9af..29e1683b9250 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -7,6 +7,7 @@
PORTNAME= anope
PORTVERSION= 1.6.3
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -109,9 +110,9 @@ pre-configure: #--{{{
.endif
# XXX Add here other arch which needs -fPIC :-)
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
- @${ECHO_CMD} CC_FLAGS=\"-O -fPIC\" >> ${CONFIG_CACHE}
+ @${ECHO_CMD} CC_FLAGS=\"${CFLAGS} -fPIC\" >> ${CONFIG_CACHE}
.else
- @${ECHO_CMD} CC_FLAGS=\"-O\" >> ${CONFIG_CACHE}
+ @${ECHO_CMD} CC_FLAGS=\"${CFLAGS}\" >> ${CONFIG_CACHE}
.endif
#}}}