aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-05-17 01:24:13 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-05-17 01:24:13 +0800
commit2cb86606bbb6674d7e48ce636ac68852527c88e4 (patch)
tree4b34842517e9fa31b12493c19e06dba16ab0cb35 /irc/bitchx/Makefile
parent84449213189c7b5c764a23bcda2152ad86d19acd (diff)
downloadfreebsd-ports-gnome-2cb86606bbb6674d7e48ce636ac68852527c88e4.tar.gz
freebsd-ports-gnome-2cb86606bbb6674d7e48ce636ac68852527c88e4.tar.zst
freebsd-ports-gnome-2cb86606bbb6674d7e48ce636ac68852527c88e4.zip
Remove tcl-freebsd.o.uu and fetch it somewhere else.
PR: 38150 Submitted by: maintainer
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 4f3b9d64f556..f94199ac9dc5 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -9,13 +9,19 @@ PORTNAME= BitchX
PORTVERSION= 1.0c19
CATEGORIES+= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
- ftp://ftp.bitchx.org/pub/BitchX/source/
+ ftp://ftp.bitchx.org/pub/BitchX/source/ \
+ ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
+ ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
DISTNAME= ircii-pana-1.0c19
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+.if defined(WITH_TCL)
+DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl
+.endif
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= freebsdports@arved.de
WRKSRC= ${WRKDIR}/BitchX
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
WANT_ESOUND= yes
@@ -52,8 +58,6 @@ CONFIGURE_ARGS+=--with-tcl \
--with-tcl-includes=${LOCALBASE}/include/tcl8.3 \
--with-tcl-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
-post-extract:
- @uudecode -p ${FILESDIR}/tcl-freebsd.o.uu > ${WRKSRC}/source/tcl.o
.endif
.if defined(WITH_SOCKS5)
@@ -95,6 +99,13 @@ pre-extract:
@${ECHO} "WITH_IPV6 - Build BitchX with IPV6 support"
.endif
+.if defined(WITH_TCL)
+
+post-extract:
+ @${CP} ${DISTDIR}/freebsd4-tcl83-bx1.0c19-tcl.o ${WRKSRC}/source/tcl.o
+
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help