aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-07-29 05:28:01 +0800
committernaddy <naddy@FreeBSD.org>2002-07-29 05:28:01 +0800
commit41c4ccbd152109498b9d2dc61124eee77ccfdba2 (patch)
tree04539de18bfb625a5bc3f391f72ab64afa4580f5 /irc/bitchx/Makefile
parent3205c365192bfa6242c36a3fc51340b6f4c1f8c5 (diff)
downloadfreebsd-ports-gnome-41c4ccbd152109498b9d2dc61124eee77ccfdba2.tar.gz
freebsd-ports-gnome-41c4ccbd152109498b9d2dc61124eee77ccfdba2.tar.zst
freebsd-ports-gnome-41c4ccbd152109498b9d2dc61124eee77ccfdba2.zip
* PERL -> REINPLACE_CMD.
* Fix plist if NOPORTDOCS is defined. * Remove dependency on autoconf213, previously added by mistake. PR: 40817 Submitted by: Tilman Linneweh <tilman@arved.de>
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile36
1 files changed, 22 insertions, 14 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index ac3d6fbd6b92..9e049c9bd952 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -29,13 +29,16 @@ LIB_DEPENDS+= xmms.3:${PORTSDIR}/audio/xmms
.endif
WRKSRC= ${WRKDIR}/BitchX
-USE_AUTOCONF= yes
+USE_REINPLACE= yes
AUTOCONF= ${LOCALBASE}/bin/autoconf
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --exec-prefix="${PREFIX}/share" \
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
--datadir="${PREFIX}/share" \
- --libdir="${PREFIX}/share"
+ --libdir="${PREFIX}/share" \
+ --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -73,7 +76,7 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.endif
.if defined(WITH_PLUGINS)
-PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
+PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
PLIST_SUB+= PLUGINS:=""
.else
CONFIGURE_ARGS+=--without-plugins
@@ -86,7 +89,7 @@ PLIST_SUB+= XMMS:=""
PLIST_SUB+= XMMS:="@comment "
.endif
.if (defined(WITH_XMMS) && defined(WITH_PLUGINS))
-PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
+PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
.endif
.if (defined(WITH_PLUGINS) || defined(WITH_XMMS))
CONFIGURE_ARGS+=--with-plugins=${PLUGINS}
@@ -94,34 +97,34 @@ CONFIGURE_ARGS+=--with-plugins=${PLUGINS}
pre-patch:
.if defined(WITH_LATIN)
- @${PERL} -pi -e "s!#undef LATIN1!#define LATIN1!" ${WRKSRC}/include/config.h
+ ${REINPLACE_CMD} -e 's|#undef LATIN1|#define LATIN1|g' ${WRKSRC}/include/config.h
.endif
- @${PERL} -pi -e "s!bzip2!true!g" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|bzip2|true|g' ${WRKSRC}/Makefile.in
pre-extract:
@${ECHO_CMD} "Available switches:"
@${ECHO_CMD} "-------------------"
.if !defined (WITH_XMMS)
- @${ECHO_CMD} "WITH_XMMS - Building BitchX with XMMS-Plugin"
+ @${ECHO_CMD} "WITH_XMMS - Building BitchX with XMMS-Plugin"
.endif
.if !defined(WITH_PLUGINS)
@${ECHO_CMD} "WITH_PLUGINS - Building BitchX with some other plugins"
.endif
.if !defined(WITH_LATIN)
- @${ECHO_CMD} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
+ @${ECHO_CMD} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
.endif
.if !defined(WITH_TCL)
- @${ECHO_CMD} "WITH_TCL - Build BitchX with TCL scripting"
+ @${ECHO_CMD} "WITH_TCL - Build BitchX with TCL scripting"
.endif
.if !defined(WITH_SOCKS5)
- @${ECHO_CMD} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
+ @${ECHO_CMD} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
.endif
.if !defined(WITH_IPV6)
- @${ECHO_CMD} "WITH_IPV6 - Build BitchX with IPV6 support"
- @${ECHO_CMD} " (Please Note: /detach is not working with IPv6)"
+ @${ECHO_CMD} "WITH_IPV6 - Build BitchX with IPV6 support"
+ @${ECHO_CMD} " (Please Note: /detach is not working with IPv6)"
.endif
.if !defined(WITH_GNOME)
- @${ECHO_CMD} "WITH_GNOME - Build BitchX with Gtk-Frontend"
+ @${ECHO_CMD} "WITH_GNOME - Build BitchX with Gtk-Frontend"
.endif
.if defined(WITH_TCL)
@@ -130,6 +133,9 @@ post-extract:
.endif
+pre-configure:
+ cd ${WRKSRC}/${dir}; ${LOCALBASE}/bin/autoconf
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help
@@ -137,6 +143,8 @@ post-install:
${TAR} --directory ${WRKSRC}/bitchx-docs -cf - . --exclude CVS | \
${TAR} --directory ${PREFIX}/share/bx/help -xf -
${INSTALL_DATA} ${WRKSRC}/doc/bxfaq.html ${PREFIX}/share/doc/bitchx
+.else
+ ${RMDIR} ${PREFIX}/share/bx/help
.endif
.include <bsd.port.mk>