aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-28 22:35:13 +0800
committerarved <arved@FreeBSD.org>2004-03-28 22:35:13 +0800
commit92cfa3a43082aeec56eb1286a136cde257636c23 (patch)
treea02d5d3bb7ae3e6e584d1442a53dfec0012d2566 /irc/bitchx/Makefile
parenta2b1a4cc174fdf05f456479cd345e2e087be1a92 (diff)
downloadfreebsd-ports-gnome-92cfa3a43082aeec56eb1286a136cde257636c23.tar.gz
freebsd-ports-gnome-92cfa3a43082aeec56eb1286a136cde257636c23.tar.zst
freebsd-ports-gnome-92cfa3a43082aeec56eb1286a136cde257636c23.zip
Update to 1.1
portlint
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile50
1 files changed, 24 insertions, 26 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index a08d29f49a8b..973d408cba33 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= BitchX
-PORTVERSION= 1.0c19
-PORTREVISION?= 4
-CATEGORIES+= irc gnome
+PORTVERSION= 1.1
+CATEGORIES+= irc
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/ \
ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
-DISTFILES= ircii-pana-${PORTVERSION}${EXTRACT_SUFX} \
- ircii-pana-${PORTVERSION}${EXTRACT_SUFX}.sig
-EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
+DISTFILES= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX} \
+ ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
MAINTAINER?= arved@FreeBSD.org
COMMENT?= "An alternative ircII color client with optional GTK/GNOME support"
@@ -46,21 +45,6 @@ MAN1= BitchX.1
# SSL "With SSL" off \
# TCL "With TCL support" off \
# XMMS "With XMMS plugin" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_TCL)
-DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
- freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
-.endif
-
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-.endif
-
-.if defined(WITH_IPV6)
-USE_AUTOCONF_VER=253
-.endif
.if defined(WITH_GNOME)
USE_X_PREFIX= yes
@@ -81,7 +65,22 @@ CONFIGURE_ARGS+=--enable-sound
USE_OPENSSL= yes
.endif
-.if ${ARCH} == "alpha" || ${ARCH} == "ia64"
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCL)
+DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
+ freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+.endif
+
+.if defined(WITH_IPV6)
+USE_AUTOCONF_VER=253
+.endif
+
+.if ${ARCH} == "alpha" || ${ARCH} == "ia64" || ${ARCH} == "amd64"
BROKEN="Dumps core on startup"
.endif
@@ -139,7 +138,7 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
- /usr/bin/dialog --yesno "SECURITY NOTICE: TCL support is only \
+ ${DIALOG} --yesno "SECURITY NOTICE: TCL support is only \
available by linking a precompiled binary object into the Application. \
Do you really want to proceed building BitchX with TCL support?" 7 70 || ${FALSE}
.endif # BATCH
@@ -153,8 +152,8 @@ pre-extract:
-gpg --keyserver pgp.mit.edu --no-default-keyring \
--keyring ${WRKDIR}/keyring --recv-key 42D1F77C
cd ${DISTDIR}; gpg --keyring ${WRKDIR}/keyring --verify \
- ircii-pana-${PORTVERSION}${EXTRACT_SUFX}.sig \
- ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
+ ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}.sig \
+ ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
.if defined(WITH_TCL)
cd ${DISTDIR}; gpg --keyring ${WRKDIR}/keyring --verify \
freebsd4-tcl83-bx1.0c19-tcl.o.sig \
@@ -210,7 +209,6 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/bitchx
${TAR} --directory ${WRKSRC}/bitchx-docs -cf - . --exclude CVS | \
${TAR} --directory ${PREFIX}/share/bx/help -xf -
- ${INSTALL_DATA} ${WRKSRC}/doc/bxfaq.html ${PREFIX}/share/doc/bitchx
.else
${RMDIR} ${PREFIX}/share/bx/help
.endif