aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-08 02:24:43 +0800
committersteve <steve@FreeBSD.org>2000-07-08 02:24:43 +0800
commitc27a7efe0bd45c170cfe1e69b76346ef3b876f53 (patch)
tree8966e27b183af992f1f3f2ee169131bf898671d4 /irc/bitchx/Makefile
parent8d39d95b4a0efde52c99c44182a99b8c2b4f525c (diff)
downloadfreebsd-ports-gnome-c27a7efe0bd45c170cfe1e69b76346ef3b876f53.tar.gz
freebsd-ports-gnome-c27a7efe0bd45c170cfe1e69b76346ef3b876f53.tar.zst
freebsd-ports-gnome-c27a7efe0bd45c170cfe1e69b76346ef3b876f53.zip
Make building the plugins optional.
PR: 19708 Submitted by: maintainer
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile32
1 files changed, 26 insertions, 6 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index ac80238c2042..b57e1f0b511b 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -27,9 +27,14 @@ WRKSRC= ${WRKDIR}/BitchX
USE_AUTOCONF= yes
USE_GMAKE= yes
.if defined(WITH_GNOME)
-CONFIGURE_ARGS+= --with-plugins --with-gtk --enable-sound
+CONFIGURE_ARGS+= --with-gtk --enable-sound
.else
-CONFIGURE_ARGS+= --with-plugins --without-gtk
+CONFIGURE_ARGS+= --without-gtk
+.endif
+.if defined(WITH_PLUGINS)
+CONFIGURE_ARGS+= --with-plugins
+.else
+CONFIGURE_ARGS+= --without-plugins
.endif
CONFIGURE_ARGS+= --exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
@@ -46,11 +51,9 @@ MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
.if !defined(WITH_GNOME)
pre-extract:
@${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
+ @${ECHO} "If you want to build the plugins define WITH_PLUGINS"
.endif
-pre-patch:
- @${PERL} -pi -e "s!#undef WANT_CHAN_NICK_SERV!#define WANT_CHAN_NICK_SERV!" ${WRKSRC}/include/config.h
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help
@@ -62,6 +65,24 @@ post-install:
@${ECHO} bin/gtkBitchX >> ${TMPPLIST}
@${ECHO} bin/gtkBitchX-1.0c16 >> ${TMPPLIST}
@${ECHO} share/bx/plugins/nicklist.so >> ${TMPPLIST}
+.if defined(WITH_PLUGINS)
+ @${ECHO} share/bx/plugins/BitchX.hints >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/acro.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/amp.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/autobot.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/blowfish.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/encrypt.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/fserv.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/hint.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/nap.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/pkga.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/possum.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/qmail.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/scan.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/wavplay.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/qbx.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/plugins >> ${TMPPLIST}
+.endif
.else
@${ECHO} bin/BitchX >> ${TMPPLIST}
@${ECHO} bin/BitchX-1.0c16 >> ${TMPPLIST}
@@ -69,7 +90,6 @@ post-install:
@${ECHO} share/bx/wserv >> ${TMPPLIST}
.endif
@${ECHO} @dirrm share/bx/help >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx/plugins >> ${TMPPLIST}
@${ECHO} @dirrm share/bx/script >> ${TMPPLIST}
@${ECHO} @dirrm share/bx/translation >> ${TMPPLIST}
@${ECHO} @dirrm share/bx >> ${TMPPLIST}