aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-17 01:27:39 +0800
committerade <ade@FreeBSD.org>2000-09-17 01:27:39 +0800
commitccef65bbbc81ded9e5a0847bbda1a740f953629e (patch)
tree864852481288b0e4952686d76c7f0a6a7439c1a5 /irc/bitchx/Makefile
parent0161dbbf879afaecce1985a767673de27380f8ba (diff)
downloadfreebsd-ports-gnome-ccef65bbbc81ded9e5a0847bbda1a740f953629e.tar.gz
freebsd-ports-gnome-ccef65bbbc81ded9e5a0847bbda1a740f953629e.tar.zst
freebsd-ports-gnome-ccef65bbbc81ded9e5a0847bbda1a740f953629e.zip
Add a new WITH_TCL hook, courtesy of Stijn Hoop <stijn@win.tue.nl>
PR: 21309 Submitted by: maintainer
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index f5ffb5e7b0cd..dbea6d977862 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -9,7 +9,7 @@ PORTNAME= BitchX
PORTVERSION= 1.0c17
CATEGORIES= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
- ftp://ftp.bitchx.org/pub/BitchX/source/ \
+ ftp://ftp.bitchx.org/pub/BitchX/source/
MAINTAINER= cj@vallcom.net
@@ -17,6 +17,10 @@ MAINTAINER= cj@vallcom.net
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
.endif
+.if defined(WITH_TCL)
+BUILD_DEPENDS= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
+.endif
+
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/BitchX
@@ -27,6 +31,11 @@ CONFIGURE_ARGS+= --with-gtk
.else
CONFIGURE_ARGS+= --without-gtk
.endif
+.if defined(WITH_TCL)
+CONFIGURE_ARGS+= --with-tcl \
+ --with-tcl-includes=/usr/local/include/tcl8.3 \
+ --with-tcl-libs=/usr/local/lib
+.endif
.if defined(WITH_ESD)
CONFIGURE_ARGS+= --enable-sound
.endif
@@ -40,8 +49,12 @@ CONFIGURE_ARGS+= --exec-prefix="${PREFIX}/share" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
+.if defined(WITH_TCL)
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
+.else
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+.endif
+CONFIGURE_ENV+= GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}"
MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
@@ -50,6 +63,11 @@ MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
pre-extract:
@${CAT} ${PKGDIR}/MESSAGE
+.if defined(WITH_TCL)
+post-extract:
+ @uudecode -p files/tcl-freebsd.o.uu > ${WRKSRC}/source/tcl.o
+.endif
+
.if defined(WITH_LATIN)
pre-patch:
@${PERL} -pi -e "s!#undef LATIN1!#define LATIN1!" ${WRKSRC}/include/config.h