aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-01-20 22:37:19 +0800
committerarved <arved@FreeBSD.org>2004-01-20 22:37:19 +0800
commitf424b82cd35205650619f5dc8e9cbda57757cbba (patch)
tree5850c8df04386a4151ab6f04edda3f448856bc75 /irc/bitchx/Makefile
parent92b95fbd1d3762911b02f1ec89eee0c1dae3b5cc (diff)
downloadfreebsd-ports-gnome-f424b82cd35205650619f5dc8e9cbda57757cbba.tar.gz
freebsd-ports-gnome-f424b82cd35205650619f5dc8e9cbda57757cbba.tar.zst
freebsd-ports-gnome-f424b82cd35205650619f5dc8e9cbda57757cbba.zip
Attempt to use the new OPTIONS feature
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile38
1 files changed, 25 insertions, 13 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index e30399e11823..8ad455412caa 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -15,25 +15,14 @@ MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
DISTFILES= ircii-pana-${PORTVERSION}${EXTRACT_SUFX} \
ircii-pana-${PORTVERSION}${EXTRACT_SUFX}.sig
-.if defined(WITH_TCL)
-DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
- freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
-.endif
EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= arved@FreeBSD.org
COMMENT?= "An alternative ircII color client with optional GTK/GNOME support"
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-.endif
-
WRKSRC= ${WRKDIR}/BitchX
USE_PERL5= yes
USE_REINPLACE= yes
-.if defined(WITH_IPV6)
-USE_AUTOCONF_VER=253
-.endif
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_TARGET=
@@ -47,6 +36,31 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= BitchX.1
+OPTIONS= ESOND "With ESOUND support" off \
+ GNOME "With GTK/GNOME1 Frontend" off \
+ IPV6 "With IPV6 support" off \
+ LATIN "Recommended if you are using an ISO-8859-1 display" off \
+ PLUGINS "With BitchX Plugins" off \
+ SOCKS5 "With SOCKS5 support" off \
+ SSL "With SSL" off \
+ TCL "With TCL support" off \
+ XMMS "With XMMS plugin" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCL)
+DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
+ freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+.endif
+
+.if defined(WITH_IPV6)
+USE_AUTOCONF_VER=253
+.endif
+
.if defined(WITH_GNOME)
USE_X_PREFIX= yes
USE_GNOME= gnomelibs
@@ -66,8 +80,6 @@ CONFIGURE_ARGS+=--enable-sound
USE_OPENSSL= yes
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "alpha" || ${ARCH} == "ia64"
BROKEN="Dumps core on startup"
.endif
cgit/cgit.cgi/freebsd-ports-gnome/commit/finance?h=mate-1.20&id=043ca95cd8d01c1e93aabd1b20e655faa5966364'>Remove this expired port.kris2004-06-215-73/+0 * Remove expired ports, plus the three ports that depended on them.kris2004-06-211-1/+0 * Update to 1.8.9.marcus2004-06-206-8/+46 * Don't use Makefile.kde anymoremarkus2004-06-061-3/+1 * Remove an extraneous dependency towards popt.thierry2004-05-291-0/+8 * - Update to version 3.0krion2004-05-296-58/+159 * Upgrade to 0.5.0 and de-gnomify.thierry2004-05-258-92/+99 * Revert previous commit; maintainer is merely having email trouble.linimon2004-05-191-1/+1 * Reset bouncing maintainer address.linimon2004-05-181-1/+1 * Reduce time and traffic by pinning distfiles to their sites.linimon2004-05-181-4/+4 * - Update to version 2.6.9krion2004-05-103-10/+10 * Fix pkg-plist.thierry2004-04-292-1/+5 * These broken ports are scheduled for deletion on June 18 if they arekris2004-04-191-0/+2 * Add missing dirrmerwin2004-04-151-0/+1 * Add missing dirrmerwin2004-04-151-0/+1 * - Update to version 1.7.9krion2004-04-104-436/+497 * - Update to version 2.9.9krion2004-04-102-3/+3 * Upgrade to 0.4.5: bug fixes.thierry2004-04-082-4/+3 * unzip is an EXTRACT_DEPENDS, not BUILD_DEPENDSkris2004-04-061-1/+1 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-054-1/+4 * - Support PTHREAD_CFLAGS properlykrion2004-04-032-12/+412 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+3 * upgrade to 0.3.5ijliao2004-04-025-314/+34 * SIZEify (maintainer timeout)trevor2004-03-319-0/+9 * - SIZEifymarkus2004-03-291-0/+1 * - Update MASTER_SITES and WWW: linekrion2004-03-262-31/+4 * Upgrade grisbi to 0.4.4.thierry2004-03-263-11/+7 * BROKEN: Checksum mismatchkris2004-03-231-0/+2 * Fix build: add missing BUILD_DEPENDS on deskutils/kdepim3lioux2004-03-21