aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitchx
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-04-23 22:21:56 +0800
committerarved <arved@FreeBSD.org>2003-04-23 22:21:56 +0800
commitbd067a5ddf1069afb1e9009fa7dc15cc60c60108 (patch)
tree0123132eb35a1541b11a8dd5f1627d7f43eeeba2 /irc/bitchx
parent24376edfca20c58cc23accd633a277aea052806c (diff)
downloadfreebsd-ports-gnome-bd067a5ddf1069afb1e9009fa7dc15cc60c60108.tar.gz
freebsd-ports-gnome-bd067a5ddf1069afb1e9009fa7dc15cc60c60108.tar.zst
freebsd-ports-gnome-bd067a5ddf1069afb1e9009fa7dc15cc60c60108.zip
Add ONLY_FOR_ARCHS= i386 to the WITH_TCL case.
Submitted by: eivind
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index d0c7585492f9..29bb756dda03 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -66,13 +66,16 @@ CONFIGURE_ARGS+=--enable-sound
USE_IPV6= yes
CONFIGURE_ARGS+=--enable-ipv6
.endif
+
.if defined(WITH_TCL)
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--with-tcl \
--with-tcl-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3
+ONLY_FOR_ARCHS= i386
.endif
+
.if defined(WITH_SOCKS5)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}