aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bitlbee-otr
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-02-17 04:59:22 +0800
committeralepulver <alepulver@FreeBSD.org>2007-02-17 04:59:22 +0800
commit5d3cf30b19571124fb8bbb4dac11fdf10f0bee9c (patch)
tree5f77e7f9e6c3d13d1d825970ff4cdb93c7858dde /irc/bitlbee-otr
parent14350188e0e67bfe58105d3f4b83ef3b8afe9cd0 (diff)
downloadfreebsd-ports-gnome-5d3cf30b19571124fb8bbb4dac11fdf10f0bee9c.tar.gz
freebsd-ports-gnome-5d3cf30b19571124fb8bbb4dac11fdf10f0bee9c.tar.zst
freebsd-ports-gnome-5d3cf30b19571124fb8bbb4dac11fdf10f0bee9c.zip
- Add DEBUG, OPENSSL and IPV6 options.
PR: ports/108689 Submitted by: Spil Oss <spil.oss@gmail.com> Approved by: Peter van Dijk <peter@dataloss.nl> (maintainer, timeout)
Diffstat (limited to 'irc/bitlbee-otr')
-rw-r--r--irc/bitlbee-otr/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/irc/bitlbee-otr/Makefile b/irc/bitlbee-otr/Makefile
index d33ac2043899..7676dbbb6f89 100644
--- a/irc/bitlbee-otr/Makefile
+++ b/irc/bitlbee-otr/Makefile
@@ -28,7 +28,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= MSN "Enable MSN protocol support" On \
LDAP "Enable LDAP authentication support" Off \
- RECODE "Enable oscar_recode_charset" Off
+ RECODE "Enable oscar_recode_charset" Off \
+ DEBUG "Create debuggable binary" Off \
+ OPENSSL "Use openssl rather than gnutls" Off \
+ IPV6 "Compile IPV6 support" On
CONFIGURE_ARGS= --mandir=${PREFIX}/man --config=${PREFIX}/etc/bitlbee
@@ -39,12 +42,17 @@ PATCHFILES+= ${PORTNAME}-1.0-ldap.diff
.endif
.if !defined(WITHOUT_MSN)
-LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--msn=1
.else
CONFIGURE_ARGS+=--msn=0 --ssl=bogus
.endif
+.if defined(WITH_OPENSSL)
+CONFIGURE_ARGS+=--ssl=openssl
+.else
+LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--ldap=${LOCALBASE}
@@ -56,6 +64,14 @@ post-patch::
${PATCH} ${PATCH_ARGS} < ${FILESDIR}/oscar-recode-patch
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--debug=1
+.endif
+
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+=--ipv6=0
+.endif
+
pre-install:
@${MKDIR} -m 700 ${PREFIX}/etc/bitlbee