aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bobot++
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 13:13:04 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 13:13:04 +0800
commit53b00caed933fbf2a25da32a4dd590a5f8033114 (patch)
tree8e4782a6af8a960d75e2de008a18466af4df4a6d /irc/bobot++
parent22b763f0b6404cf6570de5a8b8b8bace97388a19 (diff)
downloadfreebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.tar.gz
freebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.tar.zst
freebsd-ports-gnome-53b00caed933fbf2a25da32a4dd590a5f8033114.zip
Convert to new options framework
Diffstat (limited to 'irc/bobot++')
-rw-r--r--irc/bobot++/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/irc/bobot++/Makefile b/irc/bobot++/Makefile
index 9bf6dcea42b3..8e3ddcff93b8 100644
--- a/irc/bobot++/Makefile
+++ b/irc/bobot++/Makefile
@@ -17,7 +17,9 @@ COMMENT= An IRC bot written in C++
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-OPTIONS= GUILE "Use Guile scripts" on
+OPTIONS_DEFINE= GUILE
+OPTIONS_DEFAULT= GUILE
+GUILE_DESC= Use Guile scripts
GNU_CONFIGURE= yes
@@ -29,11 +31,9 @@ PLIST_FILES= bin/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GUILE)
-CONFIGURE_ARGS+= --disable-scripting
-.else
+.if ${PORT_OPTIONS:MGUILE}
LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile
CONFIGURE_ARGS+= --enable-scripting
PLIST_FILES+= share/guile/site/bobotpp/bot.scm \
@@ -42,6 +42,8 @@ PLIST_DIRS+= %%DATADIR%%/scripts \
%%DATADIR%% \
share/guile/site/bobotpp
PLIST_DIRSTRY+= share/guile/site
+.else
+CONFIGURE_ARGS+= --disable-scripting
.endif
post-patch:
@@ -49,13 +51,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|std::snprintf|snprintf|g' ${WRKSRC}/source/Bot.C
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>