aboutsummaryrefslogtreecommitdiffstats
path: root/irc/bopm
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-09 02:10:14 +0800
committertijl <tijl@FreeBSD.org>2014-09-09 02:10:14 +0800
commit5d5e6100f72b35826ebccb821fc2de9b9431144e (patch)
treea0335fc166c944ece365419f03e5b45a72eb399b /irc/bopm
parente0f2d4fdd053b14dd434913a520697e5c238d6f7 (diff)
downloadfreebsd-ports-gnome-5d5e6100f72b35826ebccb821fc2de9b9431144e.tar.gz
freebsd-ports-gnome-5d5e6100f72b35826ebccb821fc2de9b9431144e.tar.zst
freebsd-ports-gnome-5d5e6100f72b35826ebccb821fc2de9b9431144e.zip
- Convert to USES=libtool and add INSTALL_TARGET=install-strip
- Store pid file under /var/run instead of /var/log - Add patch to fix DESTDIR problems - Use @sample - Replace pkg-deinstall and @exec with @dirrmtry
Diffstat (limited to 'irc/bopm')
-rw-r--r--irc/bopm/Makefile18
-rw-r--r--irc/bopm/files/bopm.in2
-rw-r--r--irc/bopm/files/patch-Makefile.in31
-rw-r--r--irc/bopm/files/pkg-deinstall.in17
-rw-r--r--irc/bopm/files/pkg-message.in13
-rw-r--r--irc/bopm/pkg-plist18
6 files changed, 43 insertions, 56 deletions
diff --git a/irc/bopm/Makefile b/irc/bopm/Makefile
index 3ce59ee98026..2b0084fe60bc 100644
--- a/irc/bopm/Makefile
+++ b/irc/bopm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bopm
PORTVERSION= 3.1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= http://static.blitzed.org/www.blitzed.org/bopm/files/ \
ftp://rusunix.org/pub/FreeBSD/distfiles/
@@ -13,27 +13,21 @@ COMMENT= Open proxy and DNSBL monitor designed for use with ircds
LOGDIR= /var/log/${PORTNAME}
-USE_AUTOTOOLS= libtool
-LIBTOOLFILES= configure src/libopm/configure
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc --localstatedir=${LOGDIR}
-
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${LOGDIR}
+INSTALL_TARGET= install-strip
+USES= libtool
USE_LDCONFIG= yes
USE_RC_SUBR= bopm
-SUB_FILES= pkg-message pkg-deinstall
PLIST_SUB= LOGDIR=${LOGDIR}
-SUB_LIST= LOGDIR=${LOGDIR}
USERS= bopm
GROUPS= bopm
post-patch:
@${REINPLACE_CMD} \
- -e 's,data_DATA = bopm.conf.sample,data_DATA =,g' \
- -e 's,$$(sysconfdir)/bopm.conf,$$(DESTDIR)&.sample,g' \
- -e '/localstatedir/d' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} \
- -e 's,/some/path/bopm.pid,${LOGDIR}/bopm.pid,g' \
+ -e 's,/some/path/bopm.pid,/var/run/bopm.pid,g' \
-e 's,/some/path/scan.log,${LOGDIR}/scan.log,g' \
${WRKSRC}/bopm.conf.sample
diff --git a/irc/bopm/files/bopm.in b/irc/bopm/files/bopm.in
index 82b39136dd43..30388ed9b1c5 100644
--- a/irc/bopm/files/bopm.in
+++ b/irc/bopm/files/bopm.in
@@ -24,7 +24,7 @@ load_rc_config $name
: ${bopm_config="%%PREFIX%%/etc/bopm.conf"}
bopm_user="bopm"
-pidfile="%%LOGDIR%%/bopm.pid"
+pidfile="/var/run/bopm.pid"
required_files="${bopm_config}"
# NOTE: bopm behaves differently with or without the -d flag.
diff --git a/irc/bopm/files/patch-Makefile.in b/irc/bopm/files/patch-Makefile.in
new file mode 100644
index 000000000000..c4bc81892a40
--- /dev/null
+++ b/irc/bopm/files/patch-Makefile.in
@@ -0,0 +1,31 @@
+--- Makefile.in.orig 2007-05-15 20:54:14 UTC
++++ Makefile.in
+@@ -194,7 +194,7 @@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = src
+-data_DATA = bopm.conf.sample bopm.conf.blitzed
++data_DATA = bopm.conf.blitzed
+ EXTRA_DIST = ChangeLog contrib INSTALL README bopm.conf.sample bopm.conf.blitzed network-bopm
+ all: all-recursive
+
+@@ -636,14 +636,14 @@
+
+
+ install-data-local:
+- @if test -f $(sysconfdir)/bopm.conf ; then \
++ @if test -f $(DESTDIR)$(sysconfdir)/bopm.conf ; then \
+ echo "$@ will not overwrite existing $(sysconfdir)/bopm.conf"; \
+ else \
+- $(mkinstalldirs) $(sysconfdir); \
+- echo "$(INSTALL_DATA) bopm.conf.sample $(sysconfdir)/bopm.conf"; \
+- $(INSTALL_DATA) bopm.conf.sample $(sysconfdir)/bopm.conf; \
++ $(mkinstalldirs) $(DESTDIR)$(sysconfdir); \
++ echo "$(INSTALL_DATA) bopm.conf.sample $(DESTDIR)$(sysconfdir)/bopm.conf.sample"; \
++ $(INSTALL_DATA) bopm.conf.sample $(DESTDIR)$(sysconfdir)/bopm.conf.sample; \
+ fi
+- $(mkinstalldirs) $(localstatedir)
++ $(mkinstalldirs) $(DESTDIR)$(localstatedir)
+
+ uninstall-local:
+ @if test -f $(sysconfdir)/bopm.conf ; then \
diff --git a/irc/bopm/files/pkg-deinstall.in b/irc/bopm/files/pkg-deinstall.in
deleted file mode 100644
index 1efb18528816..000000000000
--- a/irc/bopm/files/pkg-deinstall.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-#-----------------------------------------------------------------------
-if [ "x$2" = "xPOST-DEINSTALL" ]; then
-#-----------------------------------------------------------------------
-
-if [ -d %%LOGDIR%% ]
-then
- rm -f %%LOGDIR%%/bopm.pid 2>/dev/null
- rmdir %%LOGDIR%% 2>/dev/null || echo "The logs in %%LOGDIR%% will remain untouched after the port is deinstalled."
-fi
-
-#-----------------------------------------------------------------------
-fi
-#-----------------------------------------------------------------------
-
-exit 0
diff --git a/irc/bopm/files/pkg-message.in b/irc/bopm/files/pkg-message.in
deleted file mode 100644
index ae25c2f16eb8..000000000000
--- a/irc/bopm/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
------------------------------------------------------------------
-bopm has been installed. Here are some installation details:
-
-user bopm (uid 717) and group bopm (gid 717) have been added
-to passwd(5) and group(5).
-
-bopm sample conf: %%PREFIX%%/etc/bopm.conf.sample
-bopm rc script: %%PREFIX%%/etc/rc.d/bopm
-bopm log dir: %%LOGDIR%%
-
-Please be sure to create %%PREFIX%%/etc/bopm.conf before
-starting this daemon.
------------------------------------------------------------------
diff --git a/irc/bopm/pkg-plist b/irc/bopm/pkg-plist
index 0afe6fee11ce..fdc3be113d7f 100644
--- a/irc/bopm/pkg-plist
+++ b/irc/bopm/pkg-plist
@@ -1,20 +1,12 @@
-@unexec /bin/echo "===>" Stopping bopm...
-@unexec /usr/bin/killall bopm 2>/dev/null || true
bin/bopm
-@owner bopm
-@group bopm
-@mode 640
-etc/bopm.conf.sample
-@owner
-@group
-@mode
+@sample(bopm,bopm,640) etc/bopm.conf.sample
include/opm.h
include/opm_error.h
include/opm_types.h
include/opm_common.h
share/bopm.conf.blitzed
-lib/libopm.so.0
-lib/libopm.so
-lib/libopm.la
lib/libopm.a
-@exec install -d -m 750 -o bopm -g bopm %%LOGDIR%% 2>/dev/null || true
+lib/libopm.so
+lib/libopm.so.0
+lib/libopm.so.0.0.0
+@dirrmtry(bopm,bopm,750) %%LOGDIR%%